如何在 Word 中使用邮件合并功能来创建和打印套用信函,使用 Excel 工作表中的数据

概要

本文介绍如何创建和打印套用信函用 Microsoft Excel 工作表中的数据,在 Microsoft Word 中使用邮件合并功能。

使用 Word 邮件合并功能时,Word 会将合并主文档与生成的输出文档的一组收件人列表:

  • 主文档包含所有输出文档中都相同的基本文本。它可能包含了信头、 文本和说明中插入的文本 (例如收件人姓名和地址)合并域到另一个输出文档而异。

  • 收件人列表是包含要合并到输出文档的数据的数据库。例如,收件人列表将 Microsoft Access 数据库文件或 Excel 工作表。

    此数据库通常是名称、 地址、 电话号码和其他个人信息的类别的列表。

  • 输出文档是邮件合并的结果。输出文档中的文本可以是相同的在所有输出文档中,但您可以将格式应用于特定的文档。

步骤 1: 设置 Excel 数据文件

在邮件合并向导开始之前,请确保您的 Excel 工作表中以及为此目的结构化。请注意该数据表格的以下要求:

  • 第一行应包含字段名称的每一列,例如,标题、 称呼、 名字、 中间名、 姓、 地址 1 和地址 2。

  • 每个字段名称应该是唯一的。

  • 每一行应提供有关特定项目的信息。例如,在邮件列表中,每行可能包括有关特定收件人的信息。

  • 表应包含没有空白的行。

创建 Excel 数据文件,然后再通过使用要用于您的信件,如下面的示例数据文件中所示的字段进行排列。

创建您的 Excel 数据文件后,保存它,并关闭该数据文件。

有关如何创建邮件合并地址列表的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

294688如何设计和设置邮件合并地址列表在 Word 2002 和更高版本的 Word 中

步骤 2: 设置主文档

  1. 在 Microsoft Office Word 2003 和早期版本的 Word 中,指向工具菜单上的信函和邮件,然后单击邮件合并向导。

    在 Microsoft Office Word 2007 中,在邮件选项卡上的开始邮件合并组中单击开始邮件合并,然后单击邮件合并向导的步骤

  2. 选择文档类型中,单击信函

    活动文档将变成主文档。主文档包含对于合并文档的每个版本都相同的图形与文本。例如,寄信人地址和在套用信函的称呼都是相同的每个版本。

  3. 单击下一步: 正在启动文档

  4. 使用下列方法之一:

    • 在文档窗口中当前显示的文档的开头。要执行此操作,请单击使用当前文档

      然后,您可以在文档窗口中键入信函内容,或等到向导会提示您这样做在后面的步骤。

    • 从模板开始。若要执行此操作,请执行以下步骤:

      1. 单击从模板开始

      2. 单击选择模板

      3. 在邮件合并选项卡上选择要包含在选择模板对话框中的模板,然后单击确定。

    • 从现有文档开始。若要执行此操作,请执行以下步骤:

      1. 单击从现有文档开始

      2. 从现有文档开始框中,选择所需的文档,然后单击打开。

      3. 如果看不到该文档,单击更多的文件,然后单击打开。在打开对话框中,找到所需的文档,然后单击打开。

  5. 单击下一步: 选择收件人

步骤 3: 指定 Excel 数据源

  1. 选择收件人中,单击使用现有列表

  2. 单击浏览

  3. 选择数据源对话框中,找到,然后单击想要使用 Excel 工作表。

    默认情况下,Word 将打开"我的数据源"文件夹。

  4. 单击打开。

  5. 如果您的 Excel 工作表中包含多个选项卡的信息,选择包含所需的信息的选项卡,然后单击确定。

  6. 在邮件合并收件人对话框中显示数据源中的所有条目。在这里,您可以优化要包含在合并中的收件人列表。

第 4 步: 选择收件人

  1. 在邮件合并收件人对话框中,选择您想要包括的收件人。若要执行此操作,请使用以下方法之一︰

    • 使用复选框来指定收件人。

      此方法是非常有用,如果该列表很短。单击以选中您想要包括的收件人旁边的复选框,然后单击以清除要排除的收件人旁边的复选框。

      注意:如果您知道要在合并中包含列表中的大部分,单击全选,然后单击以清除特定记录。同样,如果您想要包括在列表中只含有几个记录,单击全部清除,然后选择所需的记录。

    • 在列表中的项进行排序。

      此方法很有用,如果您想要按字母顺序或数字顺序查看项目。单击该元素要作为排序依据的列标题。例如,如果您想要按姓氏的字母顺序显示列表,请单击姓氏列标题。

    • 筛选列表中的项目。

      此方法很有用,如果列表包含您知道不想查看或包含在合并中的记录。筛选列表后,您可以使用复选框来包含和排除记录,如前面所述。若要筛选列表,请执行以下步骤:

      1. 单击想要作为筛选依据的元素的列标题旁边的箭头。

      2. 单击下列任一选项:

        • (空白): 此选项显示相应字段为空白的所有记录。

        • (非空白): 此选项显示其中的对应域包含信息的所有记录。

        • 如果数据源包含共享相同信息的记录,并有 10 个或更少的唯一值的列中,您可以按特定信息进行筛选。例如,如果有多个地址将国家/地区为澳大利亚,您可以按澳大利亚进行筛选。

    • 邮件合并收件人对话框中显示指定的记录。要再次显示所有记录,请单击(全部)。

    备注:

    • 高级排序和筛选,请单击任一列名称,旁边的箭头,然后单击(高级)。使用筛选器记录和对记录进行排序选项卡可以设置排序或筛选查询所需。

    • 如果您已经安装了地址验证软件,单击验证在邮件合并收件人对话框以验证收件人的地址。

  2. 单击确定以返回到邮件合并向导。

    合并的情况下,Word 将使用您指定的收件人。

  3. 单击下一步: 撰写信函

步骤 5: 完成信函并添加合并域

如果您还没有这样,键入您希望出现在每封套用信函主文档中的文本。

插入合并域

插入合并域所需的名称、 地址和其他数据源中的信息合并。要插入合并域,请执行以下步骤:

  1. 在主文档中,单击要插入域的位置。

  2. 插入下列任一操作:

    • 包含名称、 地址和其他信息的地址块:

      1. 单击地址块

      2. 在插入地址块对话框中,选择您想要包括的地址元素以及所需的格式,然后单击确定。有关某个选项的帮助,单击问号按钮,然后再单击该选项。

      3. 有关某个选项的帮助,单击问号按钮,然后再单击该选项。如果出现匹配域对话框,Word 可能无法找到某些地址块需要的信息。单击旁边的箭头
        (不可用),然后选择数据源中对应于邮件合并所需域中的域。

    • 问候语:

      1. 单击问候语。

      2. 选择问候语格式,其中包括称呼、 姓名格式和以下标点符号。

      3. 选择您希望出现在情况下,Word 不能解释收件人的名称的文本。例如,Word 不能解释名称时数据源中不包含第一个或最后一个名为收件人,而仅包含公司名。

      4. 单击确定。

      5. 如果出现匹配域对话框中,Word 可能无法找到某些信息所需要的问候语。单击(不可用),旁边的箭头,然后从对应于邮件合并所需域的数据源中选择字段。

    • 其他的信息的字段:

      1. 单击其他项目。

      2. 使用下列方法之一:

        • 单击地址字段,即使该数据源的字段与域没有相同的名称将自动映射到数据源中的相应字段的地址域中选择。

        • 单击要从始终直接从列获取数据的数据库中的字段中选择的数据库字段。

      3. 在字段框中,单击所需的字段。

      4. 单击插入,然后单击关闭。

      5. 如果出现匹配域对话框中,Word 可能无法找到某些插入该字段所需的信息。单击(不可用),旁边的箭头,然后从对应于邮件合并所需域的数据源中选择字段。

        注意:如果您插入数据库域列表中,并且稍后切换到不具有相同名称的列的数据源,Word 无法将该域信息插入合并文档。

    • 电子邮政:

      若要添加电子邮政,必须首先安装一个电子邮政程序,例如,您可以从网上第三方提供商购买。若要使用电子邮政,请执行以下步骤:

      1. 单击电子邮政。

        如果您没有安装电子邮政程序,Word 会提示您安装一个硬盘驱动器,并提供连接到下面的 Microsoft Office Web 站点:

        打印联机邮资
        http://office.microsoft.com/services/service.aspx?sid=2.4

      2. 插入电子邮政根据该程序的说明。

    • 若要添加电子邮政,必须首先安装一个电子邮政程序,例如,您可以从网上第三方提供商购买。若要使用电子邮政,请执行以下步骤: 邮政条码: 您必须选择一种支持 POSTNET 条码号或封套类型。若要使用邮政条码,请执行以下步骤:

      1. 单击邮政条码

      2. 插入邮政条码对话框中,选择适当的地址域。

        注意: 仅当您使用美国英语版的 Word,则会出现邮政条码选项。

      3. 重复步骤和 b 想要插入的所有字段。注释:

        • 不能键入的合并域字符 (""),或者通过使用插入菜单上的符号命令插入它们。

        • 如果合并字段出现在括号,如 {合并域城市},则 Word 显示的域代码而非域结果。这不会影响合并,但如果要显示结果,请右键单击域代码,再单击快捷菜单上的切换域代码。

      例如,通过使用前面所示的示例数据库,您的信中可能包含的地址块和问候语域,并因此您的第一页会显示类似于以下:

      2002 年 2 月 26日日

      地址块

      问候语

      键入您在本文中的信件。

      谨祝,

      键入您的姓名

    注意:您可以使用邮件合并工具栏插入合并域、 使用邮件合并主文档中,或运行邮件合并。要显示邮件合并工具栏,请指向工具菜单上的信函和邮件,然后单击显示邮件合并工具栏


    邮件合并工具栏提供了邮件合并向导任务窗格中未包括的其他命令。例如,可以在邮件合并工具栏上使用插入 Word 域菜单来插入 Word 域控制合并进程。例如,可以插入 IF 域插入文本,只有特定合并字段具有指定的值。

    或者,您可以单击检查错误,若要使 Word 运行邮件合并和报告在主文档中包含的任何错误。

更改合并数据的格式

若要设置合并的数据的格式,必须设置主文档中的合并域的格式。不要格式化数据源中的数据,因为在将数据合并到文档时无法保留其格式。若要更改合并数据的格式,请执行以下步骤:

  1. 在主文档中,选择包含要设置格式,信息的字段包括在封闭的合并域字符 (<> <>)。

  2. 在 Word 2003 和早期版本的 Word 中,在格式菜单上单击字体,然后选择所需的选项。

    在 Word 2007 中,请单击主页选项卡上字体组中主题字体框中所需的选项。

使用域代码的格式

控制格式的其他方面,按 ALT + F9 以显示域代码,然后将开关添加到合并域。在处理域时,开关是导致产生特定操作的特殊指令。通常情况下,将开关添加到域可修改结果。

有关如何使用开关的示例如下所示:

  • 若要显示为$ 34,987.89的编号34987.89 ,请添加数字图片开关 (\ #)。

  • 若要打印客户姓名字母均为大写,请添加格式开关 (\ *)。

  • 要确保合并的信息具有相同的字体和磅值应用于合并域,请添加 Charformat 开关 (\ *)。

第 6 步: 保存文档

在完成主文档并插入所有合并域之后,请确保您保存文档之前。若要执行此操作,请执行以下步骤:

  1. 在 Word 2003 和早期版本的 Word 中,请在文件菜单上单击另存为。

    在 Word 2007 中,单击Microsoft Office 按钮,,然后单击另存为

  2. 该文档中,命名,然后单击保存。

  3. 单击下一步: 预览信函

第 7 步: 预览信函并仔细调整收件人列表

向导显示"步骤 5 邮件合并"任务窗格中,向导将取代每个收件人列表的第一个条目的实际文本的主文档中的合并域。因此,您可以看到第一个输出文档的外观。

例如,如果您要继续使用前面所示的示例数据库,第一页应类似于下面的页单击后下一步: 预览信函:

2002 年 2 月 26日日

Andrew 祥
908 资本方式 w。
塔科马 98401

亲爱的 Andrew 祥,

键入您在本文中的信件。

谨祝,

键入您的姓名若要预览其他条目,请使用下列方法之一:

  • 若要预览项目进行排序,请单击向左或右箭头按钮。

  • 若要定位并预览指定的项,请单击查找收件人,然后在查找条目对话框中输入搜索条件。

如果您希望,微调收件人列表。若要执行此操作,请使用以下方法之一︰

  • 要在合并操作中排除特定的收件人,请单击排除此收件人

  • 若要更改收件人列表,请单击编辑收件人列表,然后在邮件合并收件人对话框中进行更改。

第 8 步: 完成合并

要完成合并,请使用以下方法之一。

对个人信函进行个性化设置

要对各个项目进行个性化设置,则实际完成合并,,,然后编辑合并的结果文档中所需的信息。若要执行此操作,请执行以下步骤:

  1. 单击编辑单个信件

  2. 合并到新文档对话框中,选择要合并的记录。

  3. 单击确定。

    Word 会创建并打开一个新的合并的文档。您的主文档还保持打开状态,并且如果您想要更改的所有文档,可以切换到它。

  4. 滚动到您想要编辑,然后再进行更改的信息。

  5. 打印或保存该文档,就像任何常规文档一样。

打印信函

要打印字母,请使用下列方法之一:

  • 如果项目进行个性化设置,并且合并的文档处于活动状态,请执行以下步骤:

    1. 在 Word 2003 和早期版本的 Word 中,在文件菜单上单击打印。

      在 Word 2007 中,单击Microsoft Office 按钮,,然后单击打印

    2. 选择所需的选项。

  • 如果想要直接从邮件合并向导进行打印,请执行以下步骤:

    1. 在步骤 6 中的邮件合并向导 (完成合并),单击打印。

    2. 合并到打印机对话框中,使用下列方法之一,然后单击确定:

      • 若要打印的所有文档,请单击全部。

      • 若要打印您在文档窗口中看到该文档,请单击当前记录

      • 若要打印的文档的范围,从,单击,然后在从和到框中键入记录号。

    3. 在打印对话框中,选择所需选项。

保存以供以后使用的合并的信函

如果要编辑合并的信函或将其保存以供以后使用,可以将它们收集到一个文档中。若要执行此操作,请执行以下步骤:

  1. 单击编辑单个信件

  2. 合并到新文档对话框中,使用下列方法之一,然后单击确定:

    • 若要合并的所有文档,请单击全部。

    • 若要合并在文档窗口中看到的文档,请单击当前记录

    • 若要合并的文档的范围,从,单击,然后在从和到框中键入记录号。

  3. Word 会打开一个新文档,其中包含所有单个字母。然后可以保存该文档以供以后使用,正如常规文档一样。

参考资料

有关详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

318117如何使用 Excel 工作表中的地址在 Word 中创建标签

318115如何在 Word 2002 中使用 Access 数据库中的信息创建套用信函

318112如何使用 Access 2002 数据库中的地址在 Word 2002 中创建的标签

294686如何使用邮件合并功能创建按类别在 Word 2002 和更高版本的 Word 中排序的列表

290408经常提出关于在 Word 2002 中邮件合并

294688如何设计和设置邮件合并地址列表在 Word 2002 和更高版本的 Word 中

294693如何使用邮件合并功能在 Word 2002 和更高版本的 Word 中创建目录

294683如何使用邮件合并功能创建套用信函,Word 2002 和更高版本的 Word 中

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

谢谢您的反馈意见!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×