安装了 VPN 软件的计算机在升级到 Windows 10 后无法检测到无线网络

症状

你的基于 Windows 8.1 的计算机安装了虚拟专用网络 (VPN) 软件。 将此计算机升级到 Windows 10 时,它可能无法再检测到无线连接。

即使在无线网络适配器工作正常的情况下也会出现此问题。 即使重启计算机或尝试重新安装无线网络适配器驱动程序,也不能修复此问题。

该问题可能还会妨碍到有线以太网连接的正常工作。 无论该连接是通过内置以太网适配器还是 USB 以太网适配器构建,均会受到这一问题的影响。

原因

如果 Windows 8.1 中安装了不受支持的 VPN 软件,且此软件在升级到 Windows 10 期间仍存在,则可能会出现此问题。 较低的软件版本包含未正确升级的筛选器驱动程序(确定性网络增强程序)。 

解决方案

重要说明 请小心遵循本节中的步骤。 对注册表更改不当可能会导致严重问题。 在更改之前,备份注册表以在出现问题时进行还原。

为了修复此问题,Microsoft 创建了一个疑难解答。

自动修复

若要自动修复此问题,请执行以下步骤:

  1. 下载疑难解答

    注意 如果计算机未连接到 Internet,请下载疑难解答,将其保存到可移动磁盘,然后将其复制到计算机。

  2. 当出现提示时,请选择“打开”。

    注意 如果出现安全警告提示,请选择“是”,以启动疑难解答。

  3. 在打开的窗口中,按照说明运行疑难解答。

手动修复

若要手动修复此问题,请执行以下步骤:

  1. 单击“开始”,然后键入“命令提示符”。

  2. 右键单击“命令提示符”,然后选择“以管理员身份运行”。

  3. 运行以下命令:

    reg delete HKCR\CLSID\{988248f3-a1ad-49bf-9170-676cbbc36ba3} /f

    netcfg -v -u dni_dne

注意 如果本文中的解决方案未能修复你的问题,或你在执行这些步骤时收到错误消息,请与 Microsoft 支持联系。

更多信息

当使用较低版本的 Cisco VPN 客户端和 SonicWall Global VPN 客户端时,已报告此问题。 客户应联系其 VPN 供应商以升级到 Windows 10 支持的软件。

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 对于这些产品的性能或可靠性,Microsoft 不做任何暗示保证或其他形式的保证。

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