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症状

尝试在订单管理 for Business Portal 3.0 和 Microsoft Dynamics GP 9.0 中搜索项目目录时,收到以下错误:

此时无法处理订单。 请稍后重试。

原因

发生此错误的原因是运行业务门户的计算机上已安装了不兼容的适用于 Microsoft Dynamics GP 9.0 的 eConnect 运行时版本。

适用于业务门户 3.0 的订单管理依赖于 eConnect Runtime 9.0.0.0。 但是,Microsoft Dynamics GP 的 Web 服务目前使用 Service Pack 1 针对 eConnect Runtime 9.0.1.0 进行编译。 如果 eConnect 运行时版本 9.0.1.0 安装在安装了订单管理 for Business Portal 3.0 的同一计算机上,则会发生此错误。

解决方法

若要解决此问题,请从计算机中删除 eConnect Runtime 9.0.1.0。 为此,请按照下列步骤操作:

  1. 单击“开始”,然后单击“控制面板”。

  2. 双击"添加或删除程序"。

  3. 选择"eConnect Runtime 9.0.1.0",然后单击"删除"。

删除 eConnect Runtime 9.0.1.0 后,从业务门户安装 CD 安装 eConnect Runtime 9.0.0.0。 若要运行安装程序,请执行以下步骤:

  1. 在业务门户安装 CD 上找到 PreReqs\eConnect 文件夹。

  2. 双击该Microsoft_Business_Solutions_eConnect_Runtime.exe文件。

更多信息

重现问题的步骤

  1. 配置适用于 Business Portal 3.0 的订单管理,然后创建订单以确认该程序是否正常工作。

  2. 从计算机中删除 eConnect Runtime 9.0.0.0。

  3. 在计算机上安装适用于 Microsoft Dynamics GP 9.0 的 Web 服务。

  4. 尝试使用订单管理 for Business Portal 3.0 创建订单。

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