备注本文假定您配置了本地 Lync Server 混合部署,并完成了以下 Microsoft TechNet 文章中介绍的所有先决条件:
准备和部署 Lync 服务器 2013 年混合环境规划的步骤,用于 Lync 服务器 2013 混合部署本文不介绍 Lync 服务器的部署或配置方案。
问题
从本地 Lync 服务器部署移动到 Skype 业务联机(以前是 Lync Online)的用户无法登录到 Skype 业务联机。
原因
如果以下一个或多个条件为 true,则可能会出现此问题:
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单一登录 (SSO) 设置不正确,用户或用户无法登录到任何 Office 365 服务。这包括微软Office 365门户。
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Lync 自动发现 DNS 记录设置不正确。在具有本地 Lync 服务器部署和 Skype 业务联机的混合部署中,Lync 自动发现的 DNS 记录必须指向本地 Lync 服务器。
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用户未从本地 Lync 池移动到 Skype 业务联机。
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在本地部署中未为 Lync 启用该用户。
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用户未获得 Office 365 门户中 Skype 业务联机许可。
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用户帐户未在 Skype 中预配业务联机。
解决 方案
若要解决此问题,请按照下列步骤操作:
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确保 SSO 工作正常。为此,请尝试登录到 Office 365 门户。如果门户上的身份验证成功,则转到下一步。
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确保 Lync Server 的本地部署的 DNS 记录设置正确。使用以下资源作为参考:
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判断用户是否已移动到 Skype 业务联机的快速方法是从本地 Lync 服务器部署检查 Lync 服务器控制面板。如果用户被移动,其家庭池将列为"LyncOnline"。 有关如何在设置初始 Lync 混合部署后移动用户的详细信息,请访问以下 TechNet 文章:
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在将用户从本地 Lync 服务器部署移动到 Skype 业务联机之前,用户必须在 Office 365 门户中获得 Skype 业务联机许可。但是,如果由于某种原因删除了用户的许可证,则他/她无法登录到 Skype 业务联机。在继续执行下一步之前,请确保用户具有有效的 Skype 业务联机许可证。
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有时,Skype 业务联机中的预配延迟可能会阻止为业务联机启用 Skype 的新用户帐户。即使为用户分配了有效的 Skype 业务联机许可证,他/她可能尚未预配。检查 Lync 管理中心以确保用户显示在业务联机用户的 Skype 列表中。
更多信息
当用户通过混合部署成功登录到 Skype 业务联机时,用户将被重定向多次,直到他或她到达 Skype 业务联机拓扑中的最终主服务器。在此处的日志示例中,您可以看到 Skype 业务联机首先到达本地 Lync Server 部署,然后重定向到用户的托管提供程序。在这种情况下,托管提供程序sipfed.online.lync.com。 将用户重定向到 Skype 业务联机托管提供商后,客户端将经历一个过程来确定用户驻留在 whicdh 中的特定池。从第一个重定向向下出现几行,类似于以下示例: 如果您没有看到重定向到 Skype 业务联机托管提供商或用户的家庭池,则执行以下操作:
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确保 Skype 业务联机托管提供程序在本地 Lync 部署中设置并正确联合。请参阅以下 TechNet 文章:
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确保用户已为 Skype 业务联机版预配和许可。
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