使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

症状

还原以前的注册表,使用scanreg /restore命令时,您可能会收到以下错误消息:

Microsoft 注册表 CheckerSystem 还原操作失败。

原因

由于您尝试还原已保存的注册表的最早版本,将发生此问题。已保存的注册表的最大数目指定 Scanreg.ini 文件中的 MaxBackupCopies 设置。当您尝试还原旧的注册表时,Windows 将尝试备份当前的注册表。因为 Windows 试图覆盖相同您尝试还原的注册表备份,还原操作将失败。注意: 旧的注册表备份仍替换当前注册表的备份并不再可用来恢复旧的注册表。

解决方案

若要解决此问题,请使用scanreg /restore命令前执行下列操作之一:

  • 重命名一个或多个其他保存的注册表备份另一个备份的留出空间。

  • 增加在 Scanreg.ini 文件中的 MaxBackupCopies 设置,以适应当前注册表的备份。

可以手动还原注册表文件中,这样可以防止当前注册表的自动备份。有关此选项的详细信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

错误消息: 恢复操作失败

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×