症状
如果单击“债务人/债权人维护 选项 ”窗口或“公司设置 选项 ”窗口,则如果“税务注册”字段留空且国家/地区代码为 GB,则无法关闭该窗口。 提供以下主题:
请输入有效的税务注册号。
“税务注册”字段的 OB 编号验证失败。
原因
如果公司/债务人/债权人的国家/地区代码设置为“GB”,并且安装了 VAT Daybook,则在 税务注册 字段上运行验证。 国家/地区代码 GB 的税务注册字段不能为空。 (在 Microsoft Dynamics GP |下授予 VAT Daybook 访问权限工具|安装|系统|使用 VAT Daybook.)
大多数情况下,用户输入了税务注册号,但没有以正确的格式输入。 它不能包含任何字母或空格。
解决方法
如果应填写“税务登记”字段,请检查以下内容:
选项 1 - 如果你有 有效的税务注册号 ,并且仍然收到此消息,则可能会错误地将其输入到 Dynamics GP 中。 验证在此字段上运行,必须输入数字而不带任何字母或空格。
例子:
你将拥有自己的公司唯一的税务登记号。
例如,如果税务登记号为: GB 999 9999 73
在 Microsoft Dynamics GP 的“税务注册”字段中输入它,如下所示: 999999973
(没有字母或空格)
选项 2 - 使用“sa”登录名进行测试,以查看系统管理员是否在同一窗口中收到相同的错误。 如果没有,则用户 ID 可能已损坏。 将问题用户的安全性复制到新的临时用户 ID,并查看用户是否遇到相同的问题。 如果没有,请删除其问题用户 ID 并重新设置。
如果“税务登记”字段应为“空白”,则解决方法为:
选项 1 - 卡在“债务人”或“债权人维护选项”窗口或“公司设置选项”窗口中时,请将“选项”窗口拖出,在“债务人”或“信用维护”窗口或“公司设置”窗口中删除“GB”的国家/地区代码。 (清除“GB”的国家/地区代码 后,必须从字段中选择 TAB 才能接受更改。) 现在可以关闭“选项”窗口。 再次在“债务人/债权人/公司”窗口上重新输入“GB”的国家/地区代码并保存。 (CR 86997)
选项2 - 如果不使用 VAT Daybook,可以通过转到 Microsoft Dynamics GP |禁用/删除对它的访问权限工具|安装|系统|使用 VAT Daybook 并取消对公司“使用增值税日志”列中的复选框进行标记。