症状
当工作文件夹在 Windows 10 中同步文件时,你会收到此错误消息:
云操作无效。
(0x8007017C)
如果满足以下条件,则会发生此错误:
-
已安装 2020 年 12 月 8 日 KB4592449 (OS 内部版本 18362.1256 和 18363.1256) 更新。
-
已启用 按需文件 访问功能。
此问题通常在新设备上设置工作文件夹或在多个设备上配置时发生。
原因
2020 年 12 月 8 日 —KB4592449 (OS 内部版本 18362.1256 和 18363.1256)更新包含应用程序编程接口 (API) 更改,导致工作文件夹无法将文件从服务器同步到设备。
解决方法
若要解决此问题,请安装以下更新之一:
-
Windows 10 版本 1809:2021年 2 月16 日-KB4601383 (OS 内部版本 17763.1790) 预览版
-
Windows 10 版本 1909:2021年 2 月16 日-KB4601380 (OS 内部版本 18363.1411) 预览版
-
Windows 10 版本 2004 或 20H2:2021年 2 月24 日-KB4601382 (OS 内部版本 19041.844 和 19042.844) 预览版
解决方法
若要解决此问题,请通过以下方法之一禁用按需文件访问功能。
方法 1:使用"工作文件夹"控制面板小程序禁用按需文件访问功能
下面将了解如何继续操作:
-
打开“控制面板”。
-
选择 "系统和安全 > 工作文件夹。
-
清除" 启用按需文件访问" 复选框。
注意:
-
确保设备的磁盘空间足够。 如果禁用该功能,则用户的所有文件都将从"工作文件夹"服务器下载到设备。
-
如果新设备上发生此问题,可以在完成从服务器到设备的同步后重新启用该功能。
方法 2:使用组策略设置禁用按需文件访问功能
下面将了解如何继续操作:
-
打开组策略管理控制台。
-
选择Windows 组件>管理模板>"工作>,>"工作文件夹"设置。
-
将按需文件访问首选项设置更改为"已禁用"。