KB3173666-在事务日志传送中将 SQL Server 2016 配置为辅助数据库时,需要使用 .NET Framework 3。5

症状

请考虑以下情况:

  • 在您的计算机上安装 SQL Server 2016。

  • 可使用事务日志传送,并将 SQL Server 2016 配置为辅助。

在这种情况下,当你在辅助设备上启动 LSCopy 作业时,可能会在未记录错误的情况下遇到故障。如果在辅助数据库上的 "SQL Server 代理" 下编辑 LSCopy 作业,请在命令行中复制并粘贴完整的 sqllogship 命令,然后按 enter,.net Framework 3.5 将按需列出。注意 在此方案中安装 .NET Framework 3.5 并重新启动服务器后, LSCopy 和 LSRestore 作业将正确运行。

解决方案

针对此问题的修复包括在 SQL Server 的以下累积更新中:

SQL Server 2016 的累积更新1

SQL Server 的每个新的累积更新均包含以前的累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:

SQL Server 2016 的最新累计更新

状态

Microsoft 已确认这是在“适用范围”部分中列出的 Microsoft 产品存在的问题。

参考

了解 Microsoft 用于描述软件更新的 术语

需要更多帮助?

扩展你的技能
了解培训
抢先获得新功能
加入 Microsoft 内部人员

此信息是否有帮助?

谢谢您的反馈意见!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×