使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

症状

在 Microsoft Outlook 2016 for Mac 或 Office for Mac 2011 中,当您尝试搜索电子邮件或将筛选器应用于文件夹时,会收到“无结果”消息,任务项不会显示在“任务”文件夹中。 此外,使用 Mac OS 本机聚焦搜索搜索邮件项目时,搜索将失败。

原因

出现此问题的原因可能为以下原因之一:


Microsoft Outlook 2016 for Mac:

  • 聚焦搜索索引不完整。

  • 配置文件名称包含特殊字符,例如斜杠标记 (/) 。

  • 配置文件或其父文件夹之一将添加到聚焦中的“隐私 ”选项卡。

  • Outlook 15 配置文件文件夹不位于 ~/Library/Group Containers/UBF8T346G9 下。Office/Outlook。

  • 聚焦搜索索引已损坏。



Microsoft Outlook for Mac 2011:

  • 聚焦搜索索引不完整。

  • 标识名称包含特殊字符,例如斜杠标记 (/) 。

  • “标识”或其父文件夹之一将添加到 Spotlight 中的“隐私 ”选项卡。

  • Microsoft 用户数据文件夹不位于 ~/Documents 文件夹下。

  • 聚焦搜索索引已损坏。

解决方案

若要解决此问题,请按照下列步骤操作:

  1. 运行 OutlookSearchRepair 实用工具。

  2. 如果最近在 Outlook 2016 for Mac 中创建了一个新的 Outlook 配置文件,或者在 Outlook for Mac 2011 中创建了一个新标识,则添加了一个新帐户,或者最近从 PST 或 OLM 文件等源导入了新数据,则聚焦索引可能不完整。 在这种情况下,Outlook for Mac显示“无结果”消息。 若要解决此问题,请等待索引完成,然后再次搜索。

  3. 请确保 Outlook 2016 for Mac 中的配置文件名称或 Outlook for Mac 2011 中的标识名称没有特殊字符,例如斜杠 (/) 。 
    若要查看配置文件或标识名称,请执行以下操作:

    Outlook 2016 for Mac:

    1. 单击“转到”,“应用程序”。

    2. Right-Click Microsoft Outlook,然后选择“显示包内容”。

    3. 展开“内容”、“SharedSupport”,然后打开 Outlook 配置文件管理器


    注意你可以为 Outlook 配置文件管理器创建别名,并根据需要将其移动到桌面或其他方便的位置。

    2011 Outlook for Mac:

    若要在 Microsoft 数据库实用工具中查看标识名称,请按住 Option 键,然后单击“Outlook for Mac 2011”图标。

  4. 如果配置文件或标识名称包含特殊字符,请按照以下步骤更改名称:

    1. 打开“Outlook 2016 for Mac配置文件”文件夹或“Outlook for Mac 2011 标识”文件夹。

      在Outlook 2016 for Mac中,位置为:
      /Users/<用户名>/Library/group Containers/UBF8T346G9。Office/Outlook/Outlook 15 配置文件/

      在 2011 Outlook for Mac中,位置为:
      Users/<用户名>/Documents/Microsoft 用户数据/Office 2011 Identities/

    2. 通过删除特殊字符重命名Outlook 2016 for Mac配置文件文件夹名称或包含特殊字符的 Outlook for Mac 2011 标识文件夹名称。

    3. 根据Outlook for Mac的版本,通过以下方式查看配置文件或标识名称,确认是否已更改:


      在 Outlook 2016 for Mac:

      1. 单击“转到”,“应用程序”。

      2. Right-Click Microsoft Outlook,然后选择“ 显示包内容”。

      3. 展开“内容”、“SharedSupport”,然后打开 Outlook 配置文件管理器


      注意 你可以为 Outlook 配置文件管理器创建别名,并根据需要将其移动到桌面或其他方便的位置。

      在 2011 Outlook for Mac:

      按住 Option 键,然后单击“Outlook for Mac 2011”图标,打开 Microsoft 数据库实用工具

    4. 如有必要,请选择名称已更改的配置文件或标识,单击“齿轮”图标,然后单击“设置为默认值”。

  5. 在 Mac OS 中验证 Outlook 配置文件或标识文件夹或其父文件夹之一是否未添加到聚焦中的“隐私”选项卡。 如果“Outlook 2016 for Mac配置文件”文件夹、Outlook for Mac 2011 Identity 文件夹或其任何父文件夹在此选项卡中显示,则 Spotlight 不会为此文件夹位置编制索引。 从聚焦的“隐私”选项卡中删除这些位置,并留出时间让这些位置完成索引编制。

  6. 确保Outlook 2016 for Mac配置文件或Outlook for Mac 2011 标识数据存储在正确的默认位置下。

    Outlook 2016 for Mac:确保 Outlook 15 配置文件文件夹存储在 ~/Library/Group Containers/UBF8T346G9 下。Office/Outlook 文件夹。

    Outlook for Mac 2011:确保 Microsoft 用户数据文件夹存储在 ~/Documents 文件夹下。

  7. 如果问题仍未解决,聚焦索引可能已损坏。 若要对 Spotlight 索引重新编制索引,请执行以下步骤:

    1. 重启 Mac,以便重启聚焦服务。

    2. 导航到 “查找器 > 应用程序 >实用工具 > 终端”。

    3. 键入 mdimport -L

    4. 重要提示:如果看到“Microsoft Outlook Spotlight Importer.mdimporter”的多个实例,请删除 使用的 Outlook 应用程序,将其从回收站清空,重启 Mac,然后返回到步骤 1。

    5. 在终端中,使用以下命令为 Outlook 数据库重新编制索引,并将自己的用户名替换为<user_name>占位符:

      mdimport -g “/Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter” -d1 “/Users/<user_name>/Library/Group Containers/UBF8T346G9。Office/Outlook/Outlook 15 配置文件/<my_profile_name>“ 

      注意 在此命令中,”-g“后面的路径是 Outlook 安装的默认路径。 “-d1”后面的路径是配置文件的默认路径,其中<my_profile_name>默认为“主配置文件”。 如果已重命名配置文件或在不同位置安装了 Outlook,则必须替换实际路径。

    6. 重新编制索引需要一些时间才能完成。 该过程完成后,退出并重启 Outlook。

如果在执行这些步骤后仍无法在 Spotlight 中搜索,并且已留出足够的时间来完成聚焦索引,则可能需要卸载Office for Mac并重新安装它。 有关具体操作方法的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章: 

2398768 如何完全删除 2011 Office for Mac

更多信息

在 Mac OS X 上搜索 Outlook 2016 for Mac 或 Outlook for Mac 2011 时,请注意以下事项:

  • Mac OS 包括聚焦搜索。 Mac OS 控制聚光搜索的硬盘的索引编制。

  • 这两个版本的Outlook for Mac都依赖于聚焦搜索来提供 Outlook 数据的搜索结果。

  • Outlook for Mac中的筛选器还依赖于聚焦搜索来提供搜索结果。

  • 使用筛选器显示Outlook for Mac中的任务。 这些筛选器依赖于聚焦搜索。

  • 引入新数据时,聚焦索引可能需要几分钟时间。 例如,在收到新电子邮件时,可能会发生这种情况。

Microsoft 提供了第三方联系信息,以便于你寻求技术支持。 该联系信息如有更改,恕不另行通知。 Microsoft 不保证此第三方联系信息的准确性。 

本文讨论的第三方产品由独立于 Microsoft 的公司制造。 对于这些产品的性能或可靠性,Microsoft 不做任何暗示保证或其他形式的保证。

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×