附註:  我們想要以您的語言,用最快的速度為您提供最新的說明內容。 本頁面是經由自動翻譯而成,因此文中可能有文法錯誤或不準確之處。讓這些內容對您有所幫助是我們的目的。希望您能在本頁底部告訴我們這項資訊是否有幫助。 此為 英文文章 出處,以供參考。

本文內容

概觀

表單範本發佈至您的使用者填寫的文件庫後,您可能需要將該表單範本移到另一個文件庫。比方說,您可能將表單範本移至伺服器的更多容量、 讓更多使用者可以填寫同時。部分使用者可能已經填寫您儲存在 [原始文件庫中的表單範本為基礎的表單。當您移動到新的文件庫的表單範本時,您會要太移動這些現有的表單。您也要確認封存或刪除舊的文件庫,將新的文件庫中使用這些現有表單。

提示: 您移至新的文件庫的發佈的表單範本之前,先建立包含通知您的使用者表單,已移至新的文件庫的計劃。要讓使用者使用新的文件庫,若要儲存新表單或修改現有的表單。計劃也應該包含封存或刪除原始文件庫的程序。

若要將表單範本與現有的表單移至新的文件庫,首先必須將工作複本的表單範本發佈至新的文件庫。使用複製為版本控制項程式,例如 Microsoft Visual SourceSafe 或電腦上儲存的版本。

提示: 如果您沒有使用複本的表單範本,您可以儲存到您的電腦,若要使用工作複本作為原始文件庫的表單範本的複本。

發佈工作複製至新的文件庫後,您需要舊的文件庫中的任何形式複製到新的文件庫,然後重新連結至新的已發佈的表單範本的新文件庫中的表單。

如果您需要進行任何變更當做移動表單範本,請在發佈表單範本之前進行這些變更。例如,此表單範本為基礎的表單,可使用外部資料來源的位置,也可能會變更當做移動表單範本。在此情況下,您需要發佈表單範本之前,變更表單範本中的資料連線至外部資料來源的新位置。尋找詳細資訊,瞭解如何變更資料連線,請參閱] 區段中的連結。

附註: 發佈表單範本無法儲存表單範本的相同。當您發佈表單範本時,發佈精靈會將發佈位置和處理指示的表單範本,讓使用者可以開啟此表單範本為基礎的表單。當您儲存表單範本時,就如同您將檔案儲存到您的電腦將表單範本的複本。當您要開放填寫您的使用者表單範本時,您應該一律使用發佈精靈。

頁面頂端

開始之前

您移動的表單範本與任何現有的表單為基礎的新文件庫的表單範本之前,您將需要下列項目:

  • 表單範本的工作副本   這是您將修改,然後重新發佈至新的文件庫的表單範本的複本。可能儲存工作複本,在您的電腦上或版本控制項程式,例如視覺 SourceSafe。

  • 任何新的外部資料來源的位置   如果表單範本為基礎的表單使用外部資料來源的變更,您需要新的外部資料來源的位置。驗證您的系統管理員和使用者可使用外部資料來源的適當權限。如果表單範本會使用連線至外部資料來源資料連線檔案中的設定,請確認的資料連線檔案已更新外部資料來源的新位置。

  • 執行Windows SharePoint Services 3.0的伺服器上適當的權限   您需要的適當權限在伺服器上發佈表單範本,並從舊的文件庫的任何現有的表單複製至新的文件庫。請洽詢您的伺服器管理員,以確定您有這些權限。

頁面頂端

取得使用表單範本的複本

如果您想要修改的表單範本發佈至文件庫或共用的網路位置,而且您不需要的表單範本,您可以儲存表單範本從發行位置,您的電腦使用的複本。

提示: 請考慮使用版本控制項程式,例如 Microsoft Visual SourceSafe,來管理您的表單範本中工作的複本。

儲存文件庫至您的電腦表單範本的複本

  1. 在網頁瀏覽器中,開啟文件庫的發佈表單範本的位置。

  2. 在 [設定] 功能表中,按一下 [設定],然後按一下表單庫設定

  3. 在 [一般設定] 下,按一下 [進階設定]。

  4. 文件範本] 區段中,按一下 [編輯範本]。

    表單範本會開啟 Microsoft Office InfoPath 中。

  5. 在 [ Microsoft Office InfoPath ] 對話方塊中,按一下[是]

  6. 按一下 [檔案] 功能表上的 [另存新檔]。

  7. 在 [ Microsoft Office InfoPath ] 對話方塊中,按一下[確定]

  8. 在 [另存新檔] 對話方塊中,瀏覽至您要儲存一份表單範本,然後再按一下 [儲存的位置。

從共用的網路資料夾的表單範本的複本儲存到您的電腦

  1. 在 [檔案] 功能表上按一下 [設計表單範本]。

  2. 開啟的表單範本,請按一下 [我的電腦上]。

  3. 瀏覽至發佈的表單範本的共用的網路資料夾,按一下 [表單範本,再按一下 [開啟

  4. 按一下 [檔案] 功能表上的 [另存新檔]。

  5. 在 [ Microsoft Office InfoPath ] 對話方塊中,按一下[確定]

  6. 在 [另存新檔] 對話方塊中,請選取的位置,不是原始發佈您要儲存的表單範本中,使用複本的位置,然後按一下 [儲存

頁面頂端

步驟 1: 將表單範本發佈至新的文件庫

  1. 在設計模式中開啟工作複本的表單範本。

  2. 在 [檔案] 功能表上按一下 [發佈]

  3. 在發佈精靈中,按一下包含或不含 InfoPath Forms Services 的到 SharePoint 伺服器],然後按 [下一步

  4. 在 [輸入您的 SharePoint 或 InfoPath Forms Services 網站的位置] 方塊中,輸入 SharePoint 網站含有您想要移動至表單範本的新文件庫的位置,然後按 [下一步

  5. 在精靈的下一個頁面上,按一下文件庫],然後按 [下一步

  6. 按一下 [建立新的文件庫],然後按一下 [下一步

  7. 在精靈的下一個頁面上,輸入的名稱和描述新的文件庫,然後再按 [下一步

  8. 選擇您想要做為資料行中的文件庫的預設檢視會顯示的表單範本中的欄位。

    如何進行?

    1. 按一下 [新增]。

    2. 選取您想要在文件庫中,以欄的方式新增的欄位,然後執行下列其中一項:

      • 在 [欄名稱] 方塊中輸入資料行的名稱。

      • 網站欄群組清單中選取網站欄,選取 [欄名稱] 清單中的名稱,然後按一下[確定]

        附註: 如果您選取資料顯示在文件庫中的重複欄位時,您可以定義要如何顯示文件庫中的欄位,按一下 [函數] 清單中的值。您可以選擇是否要顯示的欄位,最後一個值] 欄位中或計數的所有欄位的項目中的第一個值或是否要合併的所有值。

    3. 按一下 [確定]。

    尋找詳細資訊請參閱] 區段中的文件庫中的欄中顯示資料的連結。

  9. 按一下 [下一步]。

  10. 在精靈的下一個頁面上,請確認顯示的資訊正確,,,然後按一下 [發佈]

  11. 若要開啟的文件庫,並測試填寫表單為基礎的表單範本的程序,請選取 [開啟此文件庫的核取方塊,,,然後按一下 [關閉

    文件庫會在瀏覽器中開啟。當您按一下 [清單] 工具列上的 [新增此表單範本為基礎的表單會開啟 Microsoft Office InfoPath 中。

表單範本發佈至新的文件庫後,您可以複製至新的文件庫的 [從舊的文件庫的表單範本的舊版本建立的現有表單。複製現有的表單之後,您可以重新連線至表單範本的新版本的現有表單。如果您未連結的現有的表單,使用者可能無法開啟這些現有的表單。

頁面頂端

步驟 2: 複製並連結的現有表單

此程序假設這兩種文件庫執行Windows SharePoint Services 3.0在伺服器上。

  1. 在網頁瀏覽器中開啟舊版的文件庫。

  2. 在 [檢視] 功能表上按一下 [檔案總管檢視]。

  3. 按下並按住 CTRL,每個您想要移動的表單,然後選取然後以滑鼠右鍵按一下其中一個表單。

  4. Internet Explorer ] 對話方塊中,請按一下 [ ],然後按一下快顯功能表上的 [複製

  5. 開啟新的文件庫。

  6. 在 [選取的檢視,按一下 [檔案總管檢視]。

  7. 以滑鼠右鍵按一下資料夾視窗中的空白區域。

  8. Internet Explorer ] 對話方塊中,按一下 [ ],然後再按一下快顯功能表上的 [

  9. 在 [檢視] 功能表上按一下 [重新連結的文件

  10. 在 [重新連結] 欄中,選取核取方塊,為每個您想要連結至新的表單範本的表單。

  11. 在 [清單] 工具列上按一下 [重新連結選取的文件

重新連結至新的表單範本的現有表單之後,您的使用者可以變更現有的表單,將您複製到新的文件庫或填寫新發佈的表單範本為基礎的新表單。

頁面頂端

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×