Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

狀況

您正在執行一個使用已包含了在 Microsoft 主機整合伺服器 2013年或獨立的資料提供者 DB2、 第 4 版或第 5 版的 db2 的管理提供者的 SQL Server 整合服務 (SSIS) 應用程式。(這個獨立的提供者包括 Microsoft SQL Server 功能套件中)。這個應用程式匯入包含日期時間資料 (時間戳記資料型別) 的資料行。

在此情況下,您會隨機收到下列錯誤訊息︰

訊息 8114,層次 16,狀態 8,行 1
錯誤轉換資料型別 DBTYPE_DBTIMESTAMP datetime2。

原因

時間戳記值分成兩個 32 KB DDM 資料緩衝區時,可能會發生這個問題。在此情況下,時間剖析器不會如預期般轉換"時間為字串""OleDb DBTIMESTAMP 結構 」。

解決方案

Microsoft 主機整合伺服器 2013

下列的累積更新包含的修正程式可解決這個問題︰

主應用程式整合伺服器 2013年累積更新 3

主機整合伺服器 2013年的累積更新 2 的 Hotfix

使用從 Microsoft 的支援,取得主應用程式整合伺服器 2013年累積更新 2 支援的 hotfix。不過,此 Hotfix 僅用於修正本文中所述的問題。此 hotfix 只適用於發生本文所述之問題的系統。此 hotfix 可能會接受其他測試。因此,如果此問題的影響不會很嚴重,我們建議您等候含此 hotfix 的下一版軟體更新。
如果 hotfix 可供下載,在此知識庫文件頂端將出現「可用的 Hotfix」區段。如果這個區段沒有出現,請連絡 Microsoft 客戶服務及支援以取得 hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如需完整清單的 Microsoft 客戶服務及支援的電話號碼,或建立個別的服務要求,請與我們連絡

注意「 下載 Hotfix 」 表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

先決條件

您必須套用此 hotfix 之後所安裝的 Microsoft 主機整合伺服器 2013年累積的更新 2。如需有關如何取得累積更新套件,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文的詳細資訊︰

2929767累積更新 2,主機整合伺服器 2013

主機整合伺服器 2010

主機整合伺服器 2010年是累積的更新 10中包含的修正程式可解決這個問題。

DB2 的 Microsoft OLE DB 提供者 4.0

Hotfix 資訊

支援的 hotfix 可從 Microsoft 取得。不過,此 Hotfix 僅用於修正本文中所述的問題。此 hotfix 只適用於發生本文所述之問題的系統。此 hotfix 可能會接受其他測試。因此,如果此問題的影響不會很嚴重,我們建議您等候含此 hotfix 的下一版軟體更新。
如果 hotfix 可供下載,在此知識庫文件頂端將出現「可用的 Hotfix」區段。如果這個區段沒有出現,請連絡 Microsoft 客戶服務及支援以取得 hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如需完整清單的 Microsoft 客戶服務及支援的電話號碼,或建立個別的服務要求,請與我們連絡

注意「 下載 Hotfix 」 表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

DB2 的 Microsoft OLE DB 提供者 5.0

Hotfix 資訊

支援的 hotfix 可從 Microsoft 取得。不過,此 Hotfix 僅用於修正本文中所述的問題。此 hotfix 只適用於發生本文所述之問題的系統。此 hotfix 可能會接受其他測試。因此,如果此問題的影響不會很嚴重,我們建議您等候含此 hotfix 的下一版軟體更新。
如果 hotfix 可供下載,在此知識庫文件頂端將出現「可用的 Hotfix」區段。如果這個區段沒有出現,請連絡 Microsoft 客戶服務及支援以取得 hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如需完整清單的 Microsoft 客戶服務及支援的電話號碼,或建立個別的服務要求,請與我們連絡

注意「 下載 Hotfix 」 表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

狀態

Microsoft 已確認這是<套用>一節所列出的 Microsoft 產品的問題。

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×