Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

重要 在運行此修正程式之前,請儲存資料並關閉應用程式。 執行修復程式後,電腦將在 10 分鐘後重新開機。

徵狀

在執行 Windows XP、Windows Vista 或 Windows 7 的電腦上,以下位置的某些圖示被隨機變更為其他圖示:

  • 我的電腦

  • Windows 檔案總管

  • Desktop

  • 快速啟動列

原因

之所以發生這個問題,是因為圖示快取未正確更新。

解決方案

要解決此問題,第一步是登錄到具有管理員許可權的另一個使用者帳戶。 如果要執行這項操作,請依照下列步驟執行:

  1. 登出遇到圖示變更的當前使用者帳戶。

  2. 以具備系統管理員權限的使用者身份登入。

附註 該檔案必須由其他使用者刪除,因為在登出過程中,IconCache.db 檔可能會被損壞的圖示資料覆蓋。

重要 此章節、方法或工作包含有關如何修改登錄的步驟。 但是,如果您不當地修改登錄,可能會發生嚴重的問題。 因此,請務必謹慎地依照這些步驟執行。 為加強保護,請先備份登錄再進行修改。 如果發生問題,您就可以還原登錄。 如需有關如何備份和還原登錄的詳細資訊,請按下列文件編號,檢視「Microsoft 知識庫」中的文章:

如何在 Windows 中備份及還原登錄

請依照以下步驟執行來解決問題:

  1. 如果顯示「關閉開啟程式互動」對話方塊,則關閉所有打開的視窗。

  2. 建立「最大緩存圖示」登錄機碼,然後將該鍵的值設置為 2048。 如果要執行這項操作,請依照下列步驟執行:

    1. 按一下「開始」,在「搜尋」方塊中輸入regedit,然後按一下清單中顯示的 Regedit 。

    2. 找出並選取下面的登錄機碼:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer

    3. 在「編輯」功能表中按一下「新增」,然後按一下「字串值」。

    4. 輸入 MaxCachedIcons 做為值名稱,然後按下 Enter。

    5. 按兩下「最大快取圖示」 值,在「值資料」方塊中輸入 2048,然後按一下「確定」。

    6. 結束 [登錄編輯程式]。

  3. 根據您的作業系統,在下列位置中刪除「IconCache.db」。

    Windows XP

    C:\Documents and Settings\<User Name>\Local Settings\Application Data

    Windows Vista 或 Windows 7

    C:\Users\<User Name>\AppData\Local附註 <User Name>是遇到圖示更改的使用者帳戶名稱的預留位置。

其他相關資訊

MATS 套件如何修正此問題

  1. MATS 套件會掃描您的電腦,並偵測電腦是否正在執行 Windows XP、Windows Vista 或 Windows 7。

  2. MATS 套件會確認登錄子機碼中的「最大快取圖示」登錄值是否存在。 如果「最大快取圖示」登錄值並不存在,請先行建立,然後再將它設定為 2048 。 如果「最大快取圖示」的登錄值確實存在,請將它設定為 2048。

    附註此程序執行期間會顯示一個對話方塊。 這讓您可以選擇自動修正問題 (這是推薦選項) 或手動選擇個別要修正的問題。 如果您手動選擇要個別修正的問題,您必須選取對話方塊中的「圖示與資料夾自訂」或「其他」或我不知道的選項。

  3. MATS 套件確認 IconCache.db 檔案已成功刪除。

其他由 MATS 套件修正的問題

無法清空 Windows XP 或 Windows Vista 中的「資源回收筒」

Windows Vista 中出現「檔案或資料夾不存在」錯誤

「網路或檔案使用權限」或「資料夾不存在」錯誤

從 Windows XP 升級到 Windows Vista 之後無法選取多個項目

對資料夾所做的大小、檢視、圖示或位置的變更遺失

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×