Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

徵兆

當您使用 Windows Update 檢查更新時,可能不會提供下載 Windows 7 Service Pack 1 (SP1) 。

原因

在某些情況下,Windows 7 SP1 的安裝可能無法成功。 如果您的電腦發生下列任一問題,Windows 7 SP1 不會透過 Windows Update 提供,以免發生這類情況:

  • 已安裝 Windows SP1,或尚未卸載 Windows 7 SP1 的預發行版本本。

  • 必須安裝另一個更新,才能使用 Windows 7 SP1。

  • 您電腦上有一個程式無法安裝 Windows 7 SP1。

  • 您的電腦缺少安裝 Windows 7 SP1 所需的系統檔案。

解決方案

若要解決此問題,請遵循下列方法中的步驟,從方法 1 開始進行,如果方法 1 無法解決問題,請前往方法 2。

方法 1:確認尚未安裝 Windows 7 SP1,且您並未執行 Windows 7 SP1 的預發行版本本

如果要執行這項操作,請依照下列步驟執行:

  1. 按一下 [開始 Windows 圖示以滑鼠右鍵按一下 [電腦,然後按一下 屬性

  2. 查看 Windows 版本 區段:

    1. 如果 列出 Service Pack 1, 表示您的電腦上已安裝 Windows 7 SP1。

    2. 如果 Service Pack 1之後列出版本號碼 (例如v.153v.720) ,您的電腦上仍安裝 Windows 7 SP1 的發行前版本。 您必須先卸載,Windows Update 才能提供 SP1 發行版本本。 詳細資訊請參閱如何卸載

      Windows 7 SP1。

方法 2:檢查擱置的更新

更新 2454826、2534366 和 2533552 可能必須安裝在您的電腦上,Windows 7 SP1 才能在 Windows Update 中提供。

若要使用 Windows Update 安裝這些更新,請遵循下列步驟:

  1. 按一下[開始 Windows 圖示按一下 [所有程式,然後按一下Windows Update。

  2. 在功能窗格中,按一下 [檢查更新,然後等待 Windows 尋找電腦的最新更新。

  3. 如果有任何重要的更新出現,請按一下 [ 安裝更新

    通知圖示 如果系統提示您輸入系統管理員密碼或進行確認,請輸入密碼或提供確認。

  4. 如果安裝完成時系統提示您執行此操作,請重新開機電腦。

  5. 再次檢查 Windows Update,查看 Windows 7 SP1 目前是否可用。

Microsoft 下載中心也提供更新 2454826、2534366 和 2533552。 若要進一步瞭解如何安裝這些更新,請按一下下列文章編號,以在 Microsoft 知識庫中查看文章:

2534366在已安裝所有語言套件的電腦上安裝 Windows 7 Sp1 安裝失敗錯誤0xC0000009A

2533552 當您嘗試安裝 Windows 7 SP1 或 Windows Server 2008 R2 SP1 時,發生「0xC0000034」錯誤訊息的更新于
2454826提供 Windows 7 和 Windows Server 2008 R2 的 Performance 與功能更新

方法 3:確認您的電腦上未安裝不相容的 SafeCentral 版本

如果您的電腦已安裝特定版本的 SafeCentral,Windows SP1 可能不會出現在 Windows Update 中。 SafeCentral 是由 SafeCentral, Inc 所製造的安全性計畫。

如果您的電腦是使用 SafeCentral 版本 2.9.0.0 或較舊版本,您必須更新 SafeCentral,才能安裝 Windows 7SP1。

若要判斷是否安裝 SafeCentral,請遵循下列步驟:

  1. 按一下 [開始 Windows 圖示按一下 [控制台,按一下 程式,然後按一下 [程式和 功能

  2. 搜尋 SafeCentral 的程式清單。 如果安裝 SafeCentral 版本 2.9.0.0 或較舊版本,請流覽
    SafeCentral 網站以瞭解更多資訊。

方法 4:檢查您是否擁有 Intel 整合式圖形驅動程式Igdkmd32.sys或Igdkmd64.sys驅動程式是否已升級

如果您的電腦上有下列其中一個檔案,Windows 7 SP1 不會出現在 Windows Update 中。

  • Igdkmd32.sys (32 位) 版本 8.15.10.2104 到 8.15.10.2141

  • Igdkmd64.sys (64 位) 版本 8.15.10.2104 到 8.15.10.2141

已知這些驅動程式會導致使用 D2D 或 Direct2D (特定應用程式) 。 例如,如果您在某些情況下將這些驅動程式與 Windows Live Mail 一起使用,Windows Live Mail 可能會當機。

若要檢查 Intel 整合式圖形驅動程式和驅動程式版本,請遵循下列步驟:

  1. 啟動 DirectX 診斷工具。 若要這麼做,請按一下 [開始Windows 圖示,在[搜尋程式和檔案方塊中輸入 dxdiag,然後按 Enter。

  2. 按一下 [顯示] 索引標籤。

  3. 請記下驅動程式和驅動程式版本。

  4. 如果您有 Intel 整合式圖形驅動程式和驅動程式版本 8.15.10.2104 到 8.15.10.2141,請流覽電腦製造商的網站,查看是否有較新的驅動程式可用。

更新 2454826 也可以從 Microsoft 下載中心下載。 此更新可協助改善此問題的績效和功能。 若要進一步瞭解如何安裝此更新,請按一下下列文章編號以在 Microsoft 知識庫中查看文章:

2454826 Windows 7 和 Windows Server 2008 R2 提供 Performance 與功能更新

方法 5:確定您沒有使用 vLite 自訂 Windows 7 安裝

vLite 是一種協力廠商程式,用來自訂 Windows 7 的安裝。 已知 vLite 會移除某些 Windows 系統元件。 如果您知道使用 vLite 自訂 Windows 7 的安裝,您不應該預期 Windows Update 會提供您安裝 Windows 7 SP1 的選項。

有關當您使用 vLite 並嘗試安裝 Windows 7 SP1 時已知的問題的詳細資訊,請參閱安裝
Windows 7 SP1主題時,系統元件遺失的錯誤訊息。

如需如何取得獨立版本的 Windows 7 SP1,請參閱瞭解如何在 SP1 sp1 中安裝 Windows 7 Service Pack 1 (SP1) 。

解決 vLite 問題的步驟

如果您嘗試過本文所述的所有步驟,但 Windows Update 仍無法提供您安裝 Windows 7 SP1 的選項,您可以安裝 Microsoft 下載中心中的 Windows 7 SP1,解決 vLite 問題。


重要:安裝 Windows 7 SP1 的建議方法是使用 Windows Update。 若要瞭解如何使用 Windows Update 安裝 Windows 7 SP1,請參閱
安裝 Windows 7 SP1主題。 如果您決定從 Microsoft 下載中心安裝 Service Pack 以解決此問題,您應該先採取一些步驟,才能從 Microsoft 下載中心安裝 Windows 7 Service Pack 1。 如需詳細資訊,請按一下下面的文章編號,檢視「Microsoft 知識庫」中的文章:

2505743 從 Microsoft 下載中心安裝 Windows 7 Service Pack 1 之前要執行的步驟
重要:如果您沒有遵循知識庫文章 2505743 中的步驟進行,當您從 Microsoft 下載中心安裝 Service Pack 時,可能無法獲得最佳體驗。

本文討論的協力廠商產品是由與 Microsoft 無關的公司所製造。 Microsoft 不以默示或其他方式,提供與這些產品的效能或可靠性有關的擔保。

Microsoft 提供協力廠商連絡人資訊,可協助您尋找技術支援。 此連絡資訊若有變更,恕不另行通知。 Microsoft 不保證此協力廠商連絡資訊的正確性。 

方法 6:從 Microsoft 下載中心下載 Windows 7 SP1

如果您嘗試上述所有方法,但仍然無法在 Windows Update 中找到 Windows 7 SP1,請從 Microsoft 下載中心下載 Windows 7 SP1:

Windows 7 和 Windows Server 2008 R2 Service Pack 1 (KB976932)

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×