Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

徵狀

當您在 Windows 7 電腦上的任何時間升級時,您可能會收到下列錯誤訊息:

Windows 隨時升級未成功
升級。 請再次嘗試升級。


此外,您可能會在 Windows [隨時升級] 中看到下列錯誤: [更新記錄]:

  • <日期> <時間>,錯誤 WAU DoTransmogrify 失敗,因為0x800f081f 錯誤。

  • <日期> <時間>,錯誤 WAU UpgradeSKU 失敗。 結束.

  • <日期> <時間>,則 [每當升級時出錯] 錯誤時,都會失敗。

原因

如果 windows 7 Service Pack 1 (SP1) 是由 Windows 更新下載,但尚未安裝,就會發生此問題。 如需此 service pack 的詳細資訊,請按一下下列文章編號,以查看 Microsoft 知識庫中的文章:

976932 Windows 7 和 Windows Server 2008 R2 Service Pack 1 的相關資訊

解決方案

若要讓我們為您修正這個問題,請移至「為我修正」一節。 如果您想要手動修正此問題,請前往<讓我自行修正此問題>一節。

為我修正此問題



若要自動修正這個問題,請按一下 [ 修正它 ] 按鈕或 [連結]。 然後按一下 [檔案下載] 對話方塊中的 [執行],並依照 Fix it 精靈中的步驟執行。




筆記

  • 此精靈可能只提供英文版本。 不過,自動修正程式也適用於 Windows 的其他語言版本。

  • 如果您不在有問題的電腦上,您應該將修正 it 解決方案儲存至快閃記憶體磁碟機或光碟,然後在發生問題的電腦上執行。


然後,移至「此方法是否已修正問題?」一節。



讓我自行修正此問題

卸載 Windows 7 Service Pack 1

若要解決此問題,請使用 DISM 命令卸載 Service Pack 1。 若要這樣做,請針對您的 Windows 7 版本執行下列步驟。

針對32位版本的 Windows 7

  1. 按一下 [ 開始],然後在 搜尋 方塊中輸入 cmd。

  2. 以滑鼠右鍵按一下 [ cmd.exe],然後按一下 [ 以系統管理員身分執行]。

  3. 輸入下列命令,然後按 Enter:

    dism.exe/online/remove-package/packagename: Package_for_KB976932 ~ 31bf3856ad364e35 ~ x86 ~ ~ 6.1.1.17514

  4. 完成移除後,請輸入 exit,然後按 Enter。

  5. 重新啟動電腦。


針對64位版本的 Windows 7

  1. 按一下 [ 開始],然後在 搜尋 方塊中輸入 cmd。

  2. 以滑鼠右鍵按一下 [ cmd.exe],然後按一下 [ 以系統管理員身分執行]。

  3. 輸入下列命令,然後按 Enter:

    dism.exe/online/remove-package/packagename: Package_for_KB976932 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.17514

  4. 完成移除後,請輸入 exit,然後按 Enter。

  5. 重新啟動電腦。


判斷您是否已安裝 Beta 版本的 Windows 7 SP1

如果您安裝的是 Beta 版本的 Windows 7 SP1,您無法在任何時間使用 Windows 升級時立即升級。 您必須卸載 Beta 版本,然後在任何時間升級時重新開機 Windows。 若要卸載 Beta 版本,請依照適用于您的 Windows 7 版本的步驟進行。

注意如果您卸載的是 Beta 版本的 Windows 7 SP1,且持續收到錯誤,您的電腦上可能會有 Beta 版本的剩餘部分。 這些步驟也會從您的電腦清除 Beta 版本的任何剩餘部分。

針對32位版本的 Windows 7

  1. 按一下 [ 開始],然後在 搜尋 方塊中輸入 cmd

  2. 以滑鼠右鍵按一下 [ cmd.exe],然後按一下 [ 以系統管理員身分執行]。

  3. 輸入下列命令,然後按 Enter:

    dism.exe/online/remove-package/packagename: Package_for_KB976932 ~ 31bf3856ad364e35 ~ x86 ~ ~ 6.1.1.17105

  4. 完成移除後,請輸入 exit,然後按 Enter。

  5. 重新啟動電腦。


針對64位版本的 Windows 7

  1. 按一下 [ 開始],然後在 搜尋 方塊中輸入 cmd。

  2. 以滑鼠右鍵按一下 [ cmd.exe],然後按一下 [ 以系統管理員身分執行]。

  3. 輸入下列命令,然後按 Enter:

    dism.exe/online/remove-package/packagename: Package_for_KB976932 ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.1.17105

  4. 完成移除後,請輸入 exit,然後按 Enter。

  5. 重新啟動電腦。




這樣是否已修正問題?

  • 檢查該問題是否已修正。 如果問題已修正,您便已完成本節。 如果問題尚未修正,則可連絡技術支援服務

  • 我們非常感謝您提供意見反應。 若要提供意見反應或報告此方案的任何問題,請在 [幫我修正此問題] 博客中留下批註,或傳送 電子 郵件給我們。

其他相關資訊

您可能會在 Windows 的 [隨時升級] 日誌檔中看到錯誤代碼0x800f081。 這個錯誤碼指出 Windows 更新已下載 Windows 7 SP1 更新,但尚未安裝更新。 您可以查看此記錄,以查看是否發生錯誤。 Windows 升級 .log 位於下列位置:

%userprofile%\AppData\Local\Microsoft\Windows\Windows [任何時間] Upgrade\update.log
若要查看此記錄檔,以查看是否發生錯誤,請依照下列步驟執行:

  1. 按一下 [ 開始],然後按一下 [ 電腦]。

  2. 複製下列文字,按一下 [開始],然後將下列文字貼到 [搜尋] 方塊中: [

    隨時隨地升級]%userprofile%\AppData\Local\Microsoft\Windows\Windows

  3. 按一下上方 [搜尋結果] 中的 [隨時隨地升級 Windows] 資料夾。

  4. 按兩下此資料夾中的 [更新] .log 檔案。

  5. 在 [記事本] 中,按一下 [編輯] 功能表上的 [尋找]。

  6. 將下列文字複製並貼到 [ 尋找目標 ] 文字方塊,然後按一下 [ 尋找]。

    0x800f081

    如果發生錯誤,您會在記錄檔中看到如下所示的專案:

    • 2011-11-25 15:59:19,錯誤 WAU DoTransmogrify 由於錯誤0x800f081f 而失敗。

    • 2011-11-25 15:59:19,錯誤 WAU UpgradeSKU 失敗。 結束.

    • 2011-11-25 15:59:19,每次升級時錯誤 WAU 升級失敗。


    請注意,記錄檔中每個行開頭的日期和時間,會對應到記錄檔案使用資訊更新的時間。

若要解決此問題,請按照「解決」一節中的步驟進行。

參考

如需詳細資訊,請按一下下面的文章編號,檢視「Microsoft 知識庫」中的文章:

2632965 Windows 隨時升級錯誤「升級失敗。 請再次嘗試升級。在有多語種使用者介面的 Windows 7 電腦上 (MUI)

Need more help?

Want more options?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×