電腦從睡眠或休眠狀態,在 Windows 7 SP1 或 Windows Server 2008 R2 SP1 中的恢復執行之後,無法連線到已驗證的 IEEE802.1X 網路

狀況

假設 Windows 7 Service Pack 1 (SP1) 為基礎的 Windows Server 2008 R2 SP1 電腦結束休眠狀態或休眠中 IEEE802.1X 驗證網路。在此情況下,電腦可能不會取得 IP 位址,且您無法連線到網路。

原因

之所以發生這個問題,是因為新的 WMI 事件會卸除後大小 0x1000 的 WMI 事件佇列已滿。因此,元件和服務依存於這些新的 WMI 事件無法運作如預期般運作。

注意因為事件都會被丟棄,有線自動設定服務 (dot3svc) 偵測不到有線的網路連線。此外,電腦無法取得 IP 位址。

解決方案

Hotfix 資訊

支援的 hotfix 可從 Microsoft 取得。不過,此 Hotfix 僅用於修正本文中所述的問題。此 Hotfix 只適用於發生此特定問題的系統上。

如果 Hotfix 可供下載,在此知識庫文件頂端將出現<有可用的 Hotfix 供您下載>區段。如果這個區段不會出現,將要求提交給 Microsoft 客戶服務及支援取得 Hotfix。

注意如果發生其他問題,或如果需要進行疑難排解,您可能必須建立個別的服務要求。收取支援費用會套用到其他支援問題和此特定 hotfix 無法解決的問題。如 Microsoft 客戶服務及支援的電話號碼或建立個別的服務要求的完整清單,請造訪下列 Microsoft 網站︰

注意「 可下載 Hotfix 」表單會顯示 hotfix 可用的語言。如果看不到您的語言,是因為未提供該語言的 Hotfix 。

先決條件

若要套用此 hotfix,您必須執行 Windows 7 SP1 或 Windows Server 2008 R2 SP1。如需有關如何取得 Windows 7 或 Windows Server 2008 R2 service pack 的詳細資訊,請按一下下面的文件編號,檢視 「 Microsoft 知識庫 」 中的文︰

Service Pack 1 Windows 7 和 Windows Server 2008 R2 的資訊

登錄資訊

若要在此套件中使用的更新,您不需要對登錄進行任何變更。

重新啟動需求

套用此更新之後,您不需要重新啟動電腦。

更新取代資訊

此更新不會取代先前發行的更新。

此更新程式的全球版本安裝檔案具有下列表格中所列的屬性。這些檔案的日期和時間均以國際標準時間 (UTC) 列出。本機電腦上這些檔案是以您當地的時間與目前的日光節約時間 (DST) 的時差來顯示日期和時間。此外,日期和時間可能會變更當您執行特定作業時的檔案

Windows 7 和 Windows Server 2008 R2 檔案資訊附註
重要Windows 7 hotfix 及 Windows Server 2008 R2 hotfix 隨附在相同的套件中。不過,在 [Hotfix 要求] 頁面上的 Hotfix 會在這兩個作業系統下列出。若要要求套用至一或兩個作業系統的 Hotfix 套件,請選取此頁面上列在 Windows 7/Windows Server 2008 R2 之下的 Hotfix。永遠參考文件的〈套用〉一節以判斷實際套用每個 hotfix 的作業系統。

  • 可以藉由檢查檔案版本號碼來識別套用至特定產品、里程碑 (RTM、SPn) 及服務分支 (LDR、 GDR) 的檔案,如下列表格中所示:

  • GDR 服務分支只包含能解決普遍及嚴重問題之廣泛發行的修正程式。LDR 服務分支包含廣為發佈和其他的修正程式。

  • 資訊清單檔案 (.manifest) 及菊檔案 (.mum) 所安裝的每個環境都 < 其他檔案和="" windows="" server="" 2008="" r2="" 的="" windows="" 7="" 資訊=""> 一節中的 [分別列出。MUM 及資訊清單檔案,以及相關的安全性類別目錄 (.cat) 檔案皆對維護更新元件的狀態來說相當重要。安全性類別目錄檔案 (將不會為其列出屬性) 是使用 Microsoft 數位簽章簽署的。

狀態

Microsoft 已確認這是<套用>一節所列出的 Microsoft 產品的問題。

更多的資訊

如需有關軟體更新術語的詳細資訊,請按一下下面的文件編號,檢視「Microsoft 知識庫」中的文件:

用來描述 Microsoft 軟體更新標準術語的描述

其他檔案資訊

支援 x86 為基礎的所有版本 Windows 7 SP1 和 Windows Server 2008 R2 SP1 的其他檔案

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

Thank you for your feedback!

Thank you for your feedback! It sounds like it might be helpful to connect you to one of our Office support agents.

×