修復損毀的活頁簿

套用到
Microsoft 365 Excel Excel 2024 Excel 2021 Excel 2019 Excel 2016

開啟 Microsoft Excel 時若偵測到損毀的活頁簿,Excel 會自動啟動 [檔案復原] 模式,並嘗試修復活頁簿。 如果 [檔案復原] 模式沒有啟動,請嘗試使用這個手動程序來復原您的活頁簿:

  1. 按一下 [ 檔案>開啟]。
  2. 按一下包含損毀的活頁簿的位置和資料夾。
  3. 在 [開啟舊檔] 對話方塊中,選取損毀的活頁簿。
  4. 按一下 [開啟] 按鈕旁邊的箭號,然後按一下 [開啟並修復]。
    [開啟並修復] 命令
  5. 若要盡可能復原大部分的活頁簿資料,請選取 [修復]。
    如果 [修復 ] 無法復原您的資料,請選取 [擷取資料 ] 以從活頁簿擷取值和公式。

如果自動或手動修復無法運作方式,還有一些修復方法或許有助於挽救資料。 您也可以透過自動儲存活頁簿的備份或隨時建立復原檔案,採取可避免遺失工作的一些預防性措施。

從損毀的活頁簿復原資料

選擇下列其中一個方法,協助復原您的資料。 如果不成功,請嘗試其他方法。 您也可以嘗試協力廠商軟體解決方案來嘗試復原活頁簿。

重要

如果是磁碟錯誤或網路錯誤造成您無法開啟活頁簿,請將活頁簿移至不同的硬碟機或本機磁碟,再嘗試下列任一復原選項。

在 Excel 中開啟活頁簿時復原資料

  • 將活頁簿還原為上次儲存的版本:如果活頁簿在您工作期間損毀,但還沒儲存變更,您可以將活頁簿還原為上次儲存的版本:

    1. 按一下 [ 檔案>開啟]。
    2. 按兩下您在 Excel 中開啟的活頁簿名稱。
    3. 按一下 [是],重新開啟活頁簿。
      活頁簿隨即開啟,但是不含可能造成活頁簿損毀的任何已完成變更。

在您無法以 Excel 開啟活頁簿時復原資料

  • 將 Excel 中的計算選項設定為手動:嘗試將計算設定從自動變更為手動。 由於不會重新計算活頁簿,因此可能能夠開啟。

    1. 按一下[新增檔案>]。
    2. 在 [新增] 下,按一下 [空白活頁簿]。
    3. 按一下 [檔案>選項]。
    4. 在 [公式] 類別中,按一下 [計算選項] 之下的 [手動],然後按一下 [確定]。
    5. 按一下 [ 檔案>開啟]。
    6. 尋找並按兩下損毀的活頁簿以將它開啟。
  • 使用外部參照連結至損毀的活頁簿:若要只擷取資料而非公式或計算值的活頁簿活頁簿,請嘗試使用外部參照來連結至損毀的活頁簿。

    1. 按一下 [ 檔案>開啟]。

    2. 前往含有損毀活頁簿的資料夾。

    3. 以滑鼠右鍵按一下損毀活頁簿的檔案名稱,按一下 [複製],然後按一下 [取消]。

    4. 按一下[新增檔案>]。

    5. 在 [新增] 下,按一下 [空白活頁簿]。

    6. 在新活頁簿的 A1 儲存格中,鍵入 =File Name!A1 (當中的 File Name 為您在步驟 3 中所複製的損毀活頁簿的名稱),然後按 Enter。

      注意

      您只需要輸入活頁簿的名稱,不必輸入副檔名。

    7. 如果出現 [更新數值] 對話方塊,請選取損毀的活頁簿,然後按一下 [確定]。

    8. 如果出現 [選擇工作表] 對話方塊,請選取適當的工作表,然後按一下 [確定]。

    9. 選取儲存格 A1。

    10. 按一下 [常用>複製],或按 Ctrl+C。

    11. 從儲存格 A1 開始選取一個區域,其大小約與損毀活頁簿內含資料的儲存格範圍相同。

    12. 按一下 [常用>貼上],或按 Ctrl+V。

    13. 在儲存格範圍仍選取的情況下,再次按一下 [ 首頁>複製 ],或按 Ctrl+C。

    14. 按一下 [貼上] 下方的箭號 [常用]>,然後按一下 [貼上值] 底下的 [值]。
      貼上值會移除損毀活頁簿的連結,只保留資料。

  • 使用巨集從損毀的活頁簿擷取資料:如果圖表連結至損毀的活頁簿,請嘗試使用巨集來擷取圖表的來源資料。

    1. 複製下列巨集程式碼,並將它貼入模組工作表中:
      Sub GetChartValues()
      Dim NumberOfRows As Integer
      Dim X As Object
      Counter = 2
      ' Calculate the number of rows of data.
      NumberOfRows = UBound(ActiveChart.SeriesCollection(1).Values)
      Worksheets("ChartData").Cells(1, 1) = "X Values"
      ' Write x-axis values to worksheet.
      With Worksheets("ChartData")
      .Range(.Cells(2, 1), _
      .Cells(NumberOfRows + 1, 1)) = _
      Application.Transpose(ActiveChart.SeriesCollection(1).XValues)
      End With
      ' Loop through all series in the chart and write their values to
      ' the worksheet.
      For Each X In ActiveChart.SeriesCollection
      Worksheets("ChartData").Cells(1, Counter) = X.Name
      With Worksheets("ChartData")
      .Range(.Cells(2, Counter), _
      .Cells(NumberOfRows + 1, Counter)) = _
      Application.Transpose(X.Values)
      End With
      Counter = Counter + 1
      Next
      End Sub

    2. 在活頁簿中插入或刪除工作表,以滑鼠右鍵按一下其工作表索引標籤,然後將它重新命名為 ChartData。

    3. 選取您要從中擷取基本資料值的圖表。

      注意

      圖表可以內嵌在工作表上或在個別的圖表工作表中。

    4. 執行巨集。

    5. 圖表中的資料會放在 ChartData 工作表中。

頁面頂端

自動儲存活頁簿的備份複本

有了活頁簿的備份,即使您的活頁簿意外遭刪除或損毀時,仍隨時能夠存取您的資料。

  1. 按一下 [檔案>] [另存新檔]。
  2. 按一下 [ 瀏覽 ] 按鈕。
    [瀏覽] 按鈕
  3. 在 [另存新檔 ] 對話方塊中,按一下 [工具] 旁的箭號,然後按一下 [ 一般選項]。
    [工具] 功能表上的 [一般選項]
  4. 在 [一般選項] 對話方塊中,選取 [建立備份] 方塊。
    在 [一般選項] 對話方塊中的 [建立備份] 選項

頁面頂端

在設定的時間間隔自動建立復原檔案

活頁簿的復原檔案也有助於確保您的活頁簿意外遭刪除或損毀時,仍能夠存取您的資料。

  1. 按一下 [檔案>選項]。
  2. 在 儲存 類別中,在 儲存活頁簿 底下勾選 儲存自動回復資訊時間間隔 方塊,然後輸入分鐘數。 (預設值為 10。)
    [Excel 選項] 對話方塊中 [儲存] 索引標籤上的 [自動回復] 選項
  3. 在 [自動回復檔案位置] 方塊中,輸入您要儲存此復原檔案的位置。
  4. 請確認未選取 [僅針對此活頁簿停用自動回復] 方塊。

頁面頂端