您可以建立 UML 元件圖表,以顯示元件、埠、介面及其間的關係。

UML中的元件代表系統的模組部分。 行為是按照必要的介面和提供的介面定義。 元件具有具有公用屬性和作業的外部視圖,且具有具有私人屬性的內部視圖,以及實現分類器。 內部視圖顯示外部行為在內部如何實現。

範例 UML 元件圖表。

首先,開啟 UML 元件 範本,然後挑選四個選項中的一個選項。 接著 會出現 UML 元件 樣版,以及符合 UML 2.5 標準之圖形。

附註: 您必須是訂閱者,才能使用UML元件Visio 方案 2樣。 如果您有訂閱,請確定您擁有最新版本的 Visio。

啟動元件圖表

  1. 啟動 Visio。 或者,如果您已經開啟檔案,請按一下 [檔案 > 新增

  2. 前往UML元件>和資料庫>類別 。

  3. 選取空白範本或三個入門圖表的其中一個。 當您挑選您想要的範本時,請按一下 [建立。

  4. 您應該 會看到圖表旁 的圖形視窗。 如果您沒看到,請前往查看工作窗格>,然後確認已選取圖形。 如果您仍然看不到,請按一下左側的 [展開圖形 展開圖形視窗按鈕 按鈕。

  5. On the View tab, make sure the check box next to Connection Points is selected. 這會使連接點在您開始連接圖形時出現。

  6. 現在,將您想要納入圖表的圖案從圖形視窗拖曳到頁面。 若要重新命名文字標籤,請按兩下這些標籤。

元件圖形

使用時間

針對系統或應用程式中的每個功能單元使用元件圖形。

「Store」元件圖形

顯示或隱藏成型

以滑鼠右鍵按一下圖形以顯示或隱藏範本標籤。

以滑鼠右鍵按一下功能表、[顯示範本 <<文字>> 元件

子系統

您可以使用元件圖形做為包含其他元件的子系統圖形。 只要調整大小以放大,然後將其他元件放在上方。 當您看到綠色螢光筆時,放開。 從該點起,較大的圖形會做為容器,而較小的圖形會隨著它移動。

提示: 如果元件在拖曳到另一個元件上方後消失,然後按 CTRL+SHIFT+F,將其帶到最前面。

將訂單元件拖曳至上方的儲存子系統圖形

介面圖形

使用時間

  1. 當您想要 指定 類/介面的實現時,請使用提供的介面圖形。

  2. 當您要 指定 類/介面上的相依性時,請使用必要的介面。

已連接兩個介面,1:以圓形結尾的介面圖形,2:以通訊端結尾的所需介面圖形

步驟 1

將提供的 介面圖形 拖曳到頁面,然後以連接點將埠方塊排成一行。 當您在連接點周圍看到綠色螢光筆時,就表示已連接。

已黏附至元件圖形的介面圖形

步驟 2

將所需 介面圖形 拖曳到頁面,並將埠方塊與連接點一起排成一行。 當您在連接點周圍看到綠色螢光筆時,就表示已連接。

黏附至元件圖形的所需介面圖形

步驟 3

若要將提供的介面和必要的介面連接在一起,請首先選取必要的介面圖形。 然後尋找黃色控點。

所需介面圖形上的黃色控點

步驟 4

拖曳黃色控點以與提供的介面連接。

已連接至提供介面的所需介面圖形

提示連接器的介面

拉直連接器

如果連接器的轉數太多,請以滑鼠右鍵按一下它,然後按一下 [ 直線連接器

顯示多重性

如有必要,請以滑鼠右鍵按一下連接器,然後選取 [顯示多重性。 完成後,會出現四個文字方塊,您可以在其中新增詳細資料。 如果您不需要所有的文字方塊,請刪除不需要的文字方塊。

變更連接器類型

您可以變更連接器類型。 例如,您可以將關聯變更為導向關聯。 以滑鼠右鍵按一下連接器,然後按一下 [ 設定連接器類型

建立動態連接,而不是點連接

如果您預期會移動許多圖形,請考慮建立 動態連接 ,而不是點連接。

在連接器上移動或旋轉文字

您可能必須旋轉或移動連接線上的文字。 方法如下所示:

  1. 按一下頁面的空白區域,取消選取任何可能選取的內容。

  2. 在 [首頁)的[工具> 群組中,按一下 [文字區塊 [文字區塊] 按鈕

  3. 按一下包含要旋轉或移動之文字的連接器。

  4. 拖曳文字塊以移動,或使用旋轉控點或旋轉旋轉控點

  5. 完成後,請按一下 [指標工具 [指標] 按鈕

    切換回指標工具按鈕 [指標] 按鈕,文字相對於圖形會維持相同的位置。 如果您使用 指標工具 [指標] 按鈕 拖曳文字,圖形也會移動。 若要將文字與圖形獨立移動,請回到文字塊 工具 [文字區塊] 按鈕

附註: 在圖表上建立及編輯 UML 圖表 Visio 網頁版 需要Visio 方案 1 或Visio 方案 2授權 ,且需另行購買 Microsoft 365。 如需詳細資訊,請與您的系統管理員Microsoft 365。 如果您的系統管理員已開啟「自助購買」,您可以自行Visio授權。 有關詳細資料,請參閱 自助購買常見問題

範例 UML 元件圖表。

首先,開啟 UML 元件 範本,然後挑選四個選項中的一個選項。 接著 會出現 UML 元件 樣版,以及符合 UML 2.5 標準之圖形。

附註: 您必須是訂閱者,才能使用UML元件Visio 方案 2樣。 如果您有訂閱,請確定您擁有最新版本的 Visio。

啟動順序圖表

  1. 開啟Visio網頁。 

  2. 在頁面右上角附近,選取更多 範本

  3. 在圖庫中,向下捲動到 UML 元件 列,大約在頁面中間。

    列的第一個專案代表空白範本,以及配套樣板。 列的其他專案是範例圖表,其中已繪製一些圖形,可協助您快速入門。

  4. 按一下任何專案以查看較大的預覽。

  5. 當您找到想要使用的圖表時,請按一下其 [ 建立> 按鈕。

    新的圖表會以相關的樣樣在瀏覽器中開啟。

元件圖形

使用時間

針對系統或應用程式中的每個功能單元使用元件圖形。

「Store」元件圖形

顯示或隱藏成型

以滑鼠右鍵按一下圖形以顯示或隱藏範本標籤。

以滑鼠右鍵按一下功能表、[顯示範本 <<文字>> 元件

子系統

您可以使用元件圖形做為包含其他元件的子系統圖形。 只要調整大小以放大,然後將其他元件放在上方。 當您看到綠色螢光筆時,放開。 從該點起,較大的圖形會做為容器,而較小的圖形會隨著它移動。

提示: 如果元件在拖曳到另一個元件上方後消失,然後按 CTRL+SHIFT+F,將其帶到最前面。

將訂單元件拖曳至上方的儲存子系統圖形

介面圖形

使用時間

  1. 當您想要 指定 類/介面的實現時,請使用提供的介面圖形。

  2. 當您要 指定 類/介面上的相依性時,請使用必要的介面。

已連接兩個介面,1:以圓形結尾的介面圖形,2:以通訊端結尾的所需介面圖形

步驟 1

將提供的 介面圖形 拖曳到頁面,然後以連接點將埠方塊排成一行。 當您在連接點周圍看到綠色螢光筆時,就表示已連接。

已黏附至元件圖形的介面圖形

步驟 2

將所需 介面圖形 拖曳到頁面,並將埠方塊與連接點一起排成一行。 當您在連接點周圍看到綠色螢光筆時,就表示已連接。

黏附至元件圖形的所需介面圖形

步驟 3

若要將提供的介面和必要的介面連接在一起,請首先選取必要的介面圖形。 然後尋找黃色控點。

所需介面圖形上的黃色控點

步驟 4

拖曳黃色控點以與提供的介面連接。

已連接至提供介面的所需介面圖形

提示連接器的介面

拉直連接器

如果連接器的轉數太多,請以滑鼠右鍵按一下它,然後按一下 [ 直線連接器

顯示多重性

如有必要,請以滑鼠右鍵按一下連接器,然後選取 [顯示多重性。 完成後,會出現四個文字方塊,您可以在其中新增詳細資料。 如果您不需要所有的文字方塊,請刪除不需要的文字方塊。

變更連接器類型

您可以變更連接器類型。 例如,您可以將關聯變更為導向關聯。 以滑鼠右鍵按一下連接器,然後按一下 [ 設定連接器類型

建立動態連接,而不是點連接

如果您預期會移動許多圖形,請考慮建立 動態連接 ,而不是點連接。

在連接器上移動或旋轉文字

您可能必須旋轉或移動連接線上的文字。 方法如下所示:

  1. 按一下頁面的空白區域,取消選取任何可能選取的內容。

  2. 在 [首頁)的[工具> 群組中,按一下 [文字區塊 [文字區塊] 按鈕

  3. 按一下包含要旋轉或移動之文字的連接器。

  4. 拖曳文字塊以移動,或使用旋轉控點或旋轉 旋轉控點

  5. 完成後,請按一下 [指標工具 [指標] 按鈕

    切換回指標工具按鈕 [指標] 按鈕,文字相對於圖形會維持相同的位置。 如果您使用 指標工具 [指標] 按鈕 拖曳文字,圖形也會移動。 若要將文字與圖形獨立移動,請回到文字塊 工具 [文字區塊] 按鈕

將軟體程式碼的結構顯示為彼此連結之元件的元件圖表

圖說文字 1 元件圖表中,元件是一般類型,而不是實例。 若要顯示元件實例,請使用 部署圖表。

圖說文字 2 相依性表示用戶端元件會以某種方式依賴供應商元件。

  1. 在 [ Visio 2010:在 [範本類別」 下,按一下 [ 軟體,然後按一下 UML 模型圖,然後按一下 [建立> 。

  2. 在 [ 樹狀檢視中,以滑鼠右鍵按一下要包含 [元件圖 元件圖表的套件或子系統,然後在 [新增 元件圖表上,按一下 [元件圖> 。

    空白頁面會出現, 而 UML 元件 樣版會變成最頂端的樣版。 工作區會以浮水印顯示 'Component'。 代表圖表的圖示會新增到樹狀檢視。

    附註: 如果看不到樹狀檢視,請指向[UML功能表上的 [視圖>,然後按一下 [模型管理器> 。

  3. 針對您想要 代表 的每個元件,將元件圖形拖曳到繪圖頁面上。

  4. 在適當的情況下,將 介面圖形 拖曳到繪圖頁面,然後將端點黏附到元件圖形,而不將圓形黏附到元件圖形。

    新增介面至類別、元件或其他元素

    1. 在靜態結構、 元件或部署圖表中,將棒棒糖 介面 圖形拖曳到繪圖頁面上。

    2. 將端點黏附至連接點, 連接點影像 - 藍色 X 元件 類別 或其他元素上的連接點。

    3. 按兩下介面 圖形 以新增名稱、作業和其他屬性值。

      提示清單

      您也可以使用類似類的矩形 介面 圖形來表示介面。 當您想要顯示介面作業清單時,請使用此圖形。

      若要變更介面顯示的圖形類型,請以滑鼠右鍵按一下介面圖形,然後按一下 [顯示為類狀介面或顯示為Lollipop 介面

  5. 使用 相依 性圖形來表示元件之間或一個元件與另一個元件介面之間的關聯。

    指出 UML 元素之間的相依性關係

    1. 將 UML靜態結構、UML部署或UML元件樣板中的相依性圖形拖曳到繪圖頁面,並將它放在您想要關聯元素附近。

    2. 使用箭頭將端點黏附到連接點, 連接點影像 - 藍色 X 元素所依附的元素上。 將端點黏附到依附于另一個元素的元素上,而不使用箭頭連接點。

    3. 按兩下相依性以新增名稱、成見和其他屬性。

      提示: 如果您想要指出 追蹤、 細分、 使用情況或 繫結 相依性,您可以使用UML靜態結構樣樣中的追蹤、精簡、使用方式或裝訂圖形。

  6. 按兩下任何圖形以開啟 其 UML 屬性 對話方塊,您可以在此新增名稱、屬性、作業和其他屬性。

  7. 儲存圖表。

另請參閱

Visio 中的 UML 圖表 (機器翻譯)

建立 UML 通訊圖表 (機器翻譯)

建立 UML 部署圖表

建立 UML 順序圖表 (機器翻譯)

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×