使用 Microsoft 登入
登入或建立帳戶。
您好:
選取其他帳戶。
您有多個帳戶
選擇您要用來登入的帳戶。

徵兆

在 Microsoft Mac 版 Outlook 2016 或 2011 Mac 版 Office,當您嘗試搜尋電子郵件訊息或將篩選套用至資料夾時,會收到「沒有結果」訊息,而工作專案不會顯示在 [工作] 資料夾中。 此外,當您使用 Mac OS 原生 Spotlight Search 搜尋訊息項目時,搜尋失敗。

原因

此問題可能會因為下列其中一個原因而發生:


Microsoft Mac 版 Outlook 2016:

  • 焦點搜尋索引編制不完整。

  • 設定檔名稱包含特殊字元,例如斜線 (/) 。

  • 設定檔或其上層資料夾會新增至 [焦點] 中的 [隱私權 ] 索引標籤。

  • Outlook 15 設定檔資料夾不在 ~/Library/Group Containers/UBF8T346G9 底下。Office/Outlook。

  • Spotlight 搜尋索引已損毀。



Mac 版 Microsoft Outlook 2011:

  • 焦點搜尋索引編制不完整。

  • 身分識別名稱包含特殊字元,例如斜線 (/) 。

  • 身分識別或其上層資料夾之一會新增至 [焦點] 中的 [隱私 權] 索引標籤。

  • [Microsoft 使用者資料] 檔夾不在 [~/Documents] 資料夾底下。

  • Spotlight 搜尋索引已損毀。

解決方案

如果要解決這個問題,請依照下列步驟執行:

  1. 執行 OutlookSearchRepair 公用程式。

  2. 如果您最近在 Mac 版 Outlook 2016 中建立了新的 Outlook 設定檔,或在 Mac 版 Outlook 2011 中建立了新的身分識別、新增了新帳戶,或者您最近從 PST 或 OLM 檔案等來源匯入新資料,則焦點索引可能無法完成。 在此情況下,Mac 版 Outlook會顯示「沒有結果」訊息。 若要解決此問題,請等待索引編制完成,然後再次搜尋。

  3. 請確定 Mac 版 Outlook 2016 中的設定檔名稱或 Mac 版 Outlook 2011 中的身分識別名稱沒有特殊字元,例如斜線 (/) 。 
    若要檢視您的設定檔或身分識別名稱:

    Mac 版 Outlook 2016:

    1. 按一下[移至應用程式]

    2. Right-Click Microsoft Outlook,然後選取[顯示套件內容]

    3. 展開[內容]、[共用支援],然後開啟 Outlook 設定檔管理員


    注意您可以為Outlook 設定檔管理員建立別名,並視需要將別名移到您的桌面或其他方便的位置。

    Mac 版 Outlook 2011:

    若要在Microsoft 資料庫公用程式中檢視身分識別名稱,請按住 Option 鍵,然後按一下 [Mac 版 Outlook 2011] 圖示。

  4. 如果設定檔或身分識別名稱包含特殊字元,請依照下列步驟變更名稱:

    1. 開啟 [Mac 版 Outlook 2016設定檔] 資料夾或 [Mac 版 Outlook 2011 身分識別] 資料夾。

      在 Mac 版 Outlook 2016 中,位置為:
      /Users/<使用者名稱>/Library/Group Containers/UBF8T346G9。Office/Outlook/Outlook 15 設定檔/

      在 Mac 版 Outlook 2011 中,位置為:
      使用者/<使用者名稱>/Documents/Microsoft 使用者資料/Office 2011 身分識別/

    2. 移除特殊字元,重新命名Mac 版 Outlook 2016配置資料夾名稱或包含特殊字元的 Mac 版 Outlook 2011 身分識別資料夾名稱。

    3. 根據您的設定檔 Mac 版 Outlook版本,以下列方式檢視設定檔或身分識別名稱,確認已變更:


      在 Mac 版 Outlook 2016 中:

      1. 按一下[移至應用程式]

      2. Right-Click Microsoft Outlook,然後選取 [顯示套件內容]

      3. 展開[內容]、[共用支援],然後開啟 Outlook 設定檔管理員


      注意 您可以為 Outlook 設定檔管理員建立別名,並視需要將別名移到您的桌面或其他方便的位置。

      在 Mac 版 Outlook 2011 中:

      按住Option鍵,然後按一下[Mac 版 Outlook 2011] 圖示,即可開啟Microsoft 資料庫公用程式。

    4. 如有需要,請選取已變更名稱的設定檔或身分識別,按一下 [齒輪] 圖示,然後按一下 [設為預設值]

  5. 在 Mac OS 中確認 Outlook 設定檔或身分識別資料夾或其上層資料夾未新增至 Spotlight 中的 [隱私權] 索引標籤。 如果您的Mac 版 Outlook 2016設定檔資料夾、Mac 版 Outlook 2011 身分識別資料夾或其上層資料夾都會顯示在此索引標籤中,則 Spotlight 不會為此資料夾位置編制索引。 從 [焦點] 的 [隱私權] 索引標籤移除這些位置,並允許這些位置有時間完成索引編制。

  6. 確定 Mac 版 Outlook 2016 設定檔或 Mac 版 Outlook 2011 身分識別資料儲存在正確的預設位置。

    Mac 版 Outlook 2016:確認Outlook 15 設定檔資料夾是儲存在 ~/Library/Group Containers/UBF8T346G9 底下。Office/Outlook 資料夾。

    Mac 版 Outlook 2011:確認[Microsoft 使用者資料] 檔夾是儲存在 [~/Documents] 資料夾底下。

  7. 如果問題仍未解決,Spotlight 索引可能會損毀。 若要重新建立 Spotlight 索引,請遵循下列步驟:

    1. 重新開機 Mac,使其重新開機 Spotlight 服務。

    2. 流覽至 Finder > Applications > Utilities > Terminal

    3. 輸入 mdimport -L

    4. 重要:如果您看到多個「Microsoft Outlook Spotlight Importer.mdimporter」實例,請刪除 您未 使用的 Outlook 應用程式、清空 [垃圾桶]、重新開機 Mac,然後返回步驟 1。

    5. 在終端中,使用下列命令重新建立您的 Outlook 資料庫,並以您自己的使用者名稱取代<user_name>預留位置:

      mdimport -g 「/Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter」 -d1 「/Users/<user_name>/Library/Group Containers/UBF8T346G9。Office/Outlook/Outlook 15 設定檔/<my_profile_name>」

      附注在此命令中,「-g」之後的路徑是 Outlook 安裝的預設路徑。  「-d1」之後的路徑是設定檔的預設路徑,其中<my_profile_name>預設為「主要設定檔」。 如果您已重新命名設定檔,或是在不同的位置安裝 Outlook,則必須以實際路徑取代。

    6. 重新重新整理需要一些時間來完成。 完成程式後,結束並重新啟動 Outlook。

如果遵循這些步驟之後仍無法在 Spotlight 中搜尋,而且如果您已允許足夠的時間讓 Spotlight 索引編制完成,您可能必須卸載Mac 版 Office並重新安裝。 如需如何執行此動作的詳細資訊,請按一下下列文章編號以檢視 Microsoft 知識庫中的文章: 

2398768 如何完全移除 Mac 版 Office 2011

其他相關資訊

當您在 Mac OS X 上搜尋 Mac 版 Outlook 2016 或 Mac 版 Outlook 2011 時,請注意下列事項:

  • Mac OS 包含 Spotlight Search。 Mac OS 會控制 Spotlight Search 硬碟的索引編制。

  • 這兩個版本的Mac 版 Outlook仰賴 Spotlight Search 來提供 Outlook 資料的搜尋結果。

  • Mac 版 Outlook中的篩選也仰賴 Spotlight Search 來提供搜尋結果。

  • Mac 版 Outlook中的工作會使用篩選來顯示。 這些篩選器仰賴 Spotlight Search。

  • 引入新資料時,焦點編制索引可能需要幾分鐘的時間。 例如,當收到新的電子郵件訊息時,可能會發生這種情況。

Microsoft 提供協力廠商的連絡資訊,協助您尋找技術支援。 此連絡資訊若有變更,恕不另行通知。 Microsoft 不保證此協力廠商連絡資訊的正確性。 

本文討論的協力廠商產品是由與 Microsoft 無關的公司製造。 Microsoft 不以默示或其他方式,提供與這些產品的效能或可靠性有關的擔保。

需要更多協助嗎?

想要其他選項嗎?

探索訂閱權益、瀏覽訓練課程、瞭解如何保護您的裝置等等。

社群可協助您詢問並回答問題、提供意見反應,以及聆聽來自具有豐富知識的專家意見。

這項資訊有幫助嗎?

您對語言品質的滿意度如何?
以下何者是您會在意的事項?
按下 [提交] 後,您的意見反應將用來改善 Microsoft 產品與服務。 您的 IT 管理員將能夠收集這些資料。 隱私權聲明。

感謝您的意見反應!

×