Article ID: 279753 - Last Review: October 30, 2006 - Revision: 3.3

Error Message: You Do Not Have Sufficient Access to Your Machine to Connect to the Selected Printer

This article was previously published under Q279753
Notice
This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .

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SYMPTOMS

When you use the Add Printer Wizard to install a network printer, you may receive the following error message:
You do not have sufficient access to your machine to connect to the selected printer.

CAUSE

This issue may occur if the account you used to log on to the network is not a member of the local Administrators or Power Users group.

RESOLUTION

To resolve this issue, use either of the following methods.

Method 1

  1. Add your domain user account to the local Administrators group:
    1. Click Start, right-click My Computer, and then click Manage.
    2. Expand Local Users and Groups, and then click Groups.
    3. In the right pane of the Computer Management dialog box, double-click Administrators, and then click Add.
    4. In the Look in box, click your domain, click your account name, click Add, and then click OK two times.
  2. Install the network printer.

Method 2

Install the printer on a Windows 2000 print server, and then share it with users across the network. This method uses the point-and-print functionality in Windows 2000. When a user connects to a printer on a print server, the connecting client looks for the appropriate driver on the print server, and then automatically downloads it. If you use this method, make sure that you install printer drivers for all the supported operating systems in your corporate network. Note that adding printers to the print server may require that you log on as an administrator or a member of the Administrators, Print Operators or the Server Operators group.

MORE INFORMATION

For additional information about how to troubleshoot Windows 2000 printing problems, click the following article number to view the article in the Microsoft Knowledge Base:
260142  (http://support.microsoft.com/kb/260142/EN-US/ ) How to Troubleshoot Windows 2000 Printing Problems
For additional information about network printing, click the following article number to view the article in the Microsoft Knowledge Base:
246855  (http://support.microsoft.com/kb/246855/EN-US/ ) Managing Network Printing in a Windows Environment
For additional information about printing to a NetWare printer from Windows 2000-based clients, click the following article number to view the article in the Microsoft Knowledge Base:
316088  (http://support.microsoft.com/kb/316088/EN-US/ ) HOW TO: Use Gateway Services for NetWare to Share a NetWare Printer with Client Computers in Windows 2000
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

APPLIES TO
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kb3rdparty kbnetwork kbprb kberrmsg KB279753
 

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