Article ID: 826756 - Last Review: December 3, 2007 - Revision: 2.8

FIX: The Response.BinaryWrite method fails when you use it to send files that are larger than 20 MB

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

When you use the Response.BinaryWrite method to send files that are greater than 20 megabytes (MB), the send operation fails after the data that is sent exceeds 20 MB.

When you use Web Reports for Microsoft Systems Management Server 2.0 or Systems Management Server 2003, and you use Microsoft Internet Information Services (IIS) 6.0 for the host site, you may receive an authentication request for you user name and password when you request a report. This authentication request occurs if you request to run a report that returns more than 10,000 rows of data. The system makes this authentication request before it completes your request. This problem most frequently occurs for Microsoft Software Update Service (SUS) reports. SUS reports frequently include more than 10,000 rows of data.

CAUSE

This problem occurs because the Active Server Pages (ASP) page buffers the data into 2 KB chunks for each send operation. Because the Http.sys driver permits only 10,000 chunks for each send operation, any file that is greater than 20 MB causes the Http.sys driver to prematurely end the data transfer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You may have to restart the computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   ---------------------------------------------------
   07-Aug-2003  21:05  6.0.3790.75  378,880  Asp.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Internet Information Services 6.0
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbfix kbbug kbqfe kbwinserv2003presp1fix KB826756
 

Article Translations

 

Related Support Centers