Article ID: 836533 - Last Review: December 3, 2007 - Revision: 1.9

You receive a "The security context is invalid" error message when you call or create an out-of-process component

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SYMPTOMS

If a Web site program has been configured for Delegation security in the Component Services management tool, and the Web site is configured for Basic authentication, you may receive the following error message when you try to call or to create an out-of-process component that is on the same computer as Microsoft Internet Information Services (IIS):
0x800706d5, "The security context is invalid."

CAUSE

This problem may occur when the user token that is generated from Basic authentication has the SecurityImpersonation impersonation level instead of the SecurityDelegation impersonation level.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must stop and then restart Internet Information Services after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name          Platform
   ----------------------------------------------------------------------
   26-Feb-2004  19:48  6.0.3790.134  339,968  W3core.dll         X86
   26-Feb-2004  19:48  6.0.3790.134  945,664  W3core.dll         IA64
   19-Jan-2004  22:54                    271  Branches.inf
   26-Feb-2004  19:55                  9,766  Kb836533.cat
   26-Feb-2004  19:49                    354  Updatebr.inf
   26-Feb-2004  19:50                  6,262  Update_rtmqfe.inf
Note This hotfix corrects this problem by using the DuplicateTokenEx function to change the token's impersonation level to SecurityDelegation.

WORKAROUND

To work around this problem, use Integrated security. Integrated security uses Kerberos.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Internet Information Services 6.0
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB836533
 

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