Internet Information Services 6.0 may not function correctly after installing KB973917

Article translations Article translations
Article ID: 2009746 - View products that this article applies to.
Expand all | Collapse all

Symptoms

Consider the following scenario.  You have an Internet Information Services (IIS) 6.0 web server running on Windows Server 2003 Service Pack 2.  The Microsoft update KB982666 and/or Microsoft update KB973917 gets installed on the server.  After installing KB98266 and/or KB973917, the IIS 6.0 application pools cannot start up successfully.  An inspection of the event logs show that the IIS worker processes are terminating unexpectedly, showing event messages similar to the following:

 

Event Type: Warning
Event Source: W3SVC
Event Category: None
Event ID: 1009
Date:  12/9/2009
Time:  10:55:01 AM
User:  N/A
Computer: WEBSERVER01
Description:
A process serving application pool 'DefaultAppPool' terminated unexpectedly. The process id was '1234'.
The process exit code was '0xffffffff'. 

 

In some cases, the IIS application pool(s) are eventually disabled by the Rapid Fail Protection feature.  Users who try browsing to the web sites hosted on the server may complain that the web sites are unavailable and cannot be accessed.

 

Cause

Previous to the installation of the KB982666 and/or KB973917 update, one or more of the core IIS .dll files were not at the correct file version.  Specifically, the earlier installation of Windows Server 2003 Service Pack 2 on the server did not complete successfully, leaving some of the IIS .dlls at the Service Pack 1 level while bringing others up to the Service Pack 2 level.  (This can occur when installing IIS onto a system running Windows Server 2003 Service Pack 2 by pointing the installer to a Windows Server 2003 Service Pack 1 media location). The IIS services had been able to run successfully even with that file mismatch in place.  However, the installation of the KB982666 and/or KB973917 update exposes this pre-existing file mismatch environment to the degree that IIS is now unable to function properly. 

 

Resolution

To resolve this problem, reinstall Service Pack 2 for Windows Server 2003 on the web server.  This will bring all IIS 6.0 components up to the correct file versions, and will maintain the installation of the KB973917 update.  Reinstalling the KB98266 and/or KB973917 update should not be necessary.

NOTE: Re-installing SP2 will enable Scalable Networking Pack (SNP) Feature that is on by default with Windows 2003 Service Pack 2. When service pack 2 was originally released this caused the issues documented in the following KB: http://support.microsoft.com/kb/948496

It may be necessary to disable the Scalable Networking Pack after re-applying Service Pack 2 to address the issues described in KB 948496

 

More Information

Microsoft has confirmed that this is a problem in the products listed in the Applies To section.  After reinstalling Service Pack 2 for Windows Server 2003, verify the file versions of the KB973917 update by reviewing the following article:

Description of the update that implements Extended Protection for Authentication in Internet Information Services (IIS)
http://support.microsoft.com/kb/973917

 

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2009746 - Last Review: July 12, 2010 - Revision: 17.0
APPLIES TO
  • Microsoft Internet Information Services 6.0, when used with:
    • Microsoft Windows Server 2003 Service Pack 2
Keywords: 
KB2009746

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com