Article ID: 221134 - Last Review: January 24, 2007 - Revision: 2.1

Some Images, Contents, or Controls May Not Be Displayed When Viewing a Web Page

This article was previously published under Q221134
Expand all | Collapse all

SYMPTOMS

When you view a Web page with a large number of images, or with images or components that are large in size, some images may not be displayed.

CAUSE

After Internet Explorer has downloaded the base Hypertext Markup Language (HTML) document, it starts downloading needed files from the server two at a time, as defined by the HTTP 1.1 specification.

Files to be downloaded are queued. Once the time-out value of five minutes has been reached for a file, the remaining files are not downloaded, and are therefore not displayed.

RESOLUTION

To work around this behavior, view another Web page and then return to the Web page. This causes Internet Explorer to begin downloading images again, picking up where it left off. Depending on the number of files to be downloaded, and the speed of your connection, you may have to repeat this process to get all of the components to be displayed.

NOTE: Using the Refresh button does not work around this issue. The Refresh button starts downloading the images again, starting over with the first image.

MORE INFORMATION

HTTP 1.1 provides enhanced Web performance between browsers and servers. Web communications using HTTP 1.1 require fewer delays and consume less bandwidth, and Web content is downloaded to the browser faster. By default, HTTP 1.1 communications are enabled in Internet Explorer to optimize browser performance when communicating with servers that support HTTP 1.1.

APPLIES TO
  • Microsoft Internet Explorer 5.0
Keywords: 
kbenv kbprb KB221134
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.
 

Article Translations

 

Related Support Centers