WD2000: How to Create an Index in a Master Document

Article translations Article translations
Article ID: 260833 - View products that this article applies to.
This article was previously published under Q260833
Expand all | Collapse all

SUMMARY

You can create an index in a master document similar to the way that you create an index in a normal Word document. This article describes how to create an index in a master document.

MORE INFORMATION

Before you can build an index, you must mark the text that you want to include in the index by using Index Entry ({XE}) fields. To do this, follow these steps:
  1. On the View menu, click Outline.
  2. If the subdocuments are collapsed, expand them. To do this, click Expand Subdocument on the Outlining toolbar. If you see only the headings of the subdocuments, click Show All Headings on the Outlining toolbar.
  3. In each subdocument, follow these steps to mark index entries for words or phrases:
    1. To use existing text as an index entry, select the text. If you want to enter your own text as an index entry, click where you want to insert the index entry.

      NOTE: Selected text automatically appears in the Main Entry box in the Mark Index Entry dialog box. If you click where you want to insert the index entry, the Main Entry box in the Mark Index Entry dialog box will be blank, and you can type the text that you want to appear in your finished index.
    2. On the Insert menu, click Index and Tables. On the Index tab, click Mark Entry to open the Mark Index Entry dialog box.

      NOTE: You can also press ALT+SHIFT+X to open the Mark Index Entry dialog box.
    3. Type or edit the text in the Main entry box.

      If you want to create a subentry, specify the main index entry, and then type the subentry in the Subentry box. To include a third-level entry, type the subentry text followed by a colon (:) and then the text of the third-level entry.
    4. To mark the index entry, click Mark. Or, if you want to mark all occurrences of this text in the document, click Mark All.
    NOTES

    • Mark All is available only if you selected text before you opened the dialog box--not if you typed your own text in the dialog box.
    • Mark All marks the first occurrence in each paragraph of text that exactly matches the uppercase and lowercase letters in the entry.
    • Word inserts each marked index entry as an XE (Index Entry) field in hidden text format. If you do not see the XE field, do one of the following:
      • Click Show/Hide on the Standard toolbar to turn on Show/Hide.

        -or-
      • On the Tools menu, click Options. On the View tab, click to select the Hidden text check box, and then click OK.
    • Because the Mark Index Entry dialog box is a modeless dialog box, you can keep the dialog box open and work on the document at the same time. To create additional index entries, click in the document, select the text or click immediately after it, click in the Mark Index Entry dialog box, and then repeat steps c and d.
  4. After you mark all the index entries that you want, click where you want to insert the index, and then follow these steps:
    1. To make sure that the document is paginated correctly, hide field codes and hidden text. If the Index Entry fields are visible, do one of the following:
      • Click Show/Hide on the Standard toolbar to turn off Show/Hide.

        -or-
      • On the Tools menu, click Options. On the View tab, click to clear the Hidden text check box, and then click OK.
    2. On the Insert menu, click Index and Tables, and then click the Index tab.
    3. If you are building an index for text in another language, select the language in the Language box.

      NOTE: The Language box includes a list of the editing languages that are turned on (enabled). Additional language options may also be available, depending on the language that you selected.
    4. Do one of the following:
      • To use one of the available designs, click a design in the Formats box.

        -or-
      • To design a custom index layout, choose the options that you want.
    5. Click OK.

How to Edit, Format, or Delete Index Entries

When you mark text with an index entry, Word inserts an XE (Index Entry) field. To change an index entry, you must modify the text in the XE field. To do this, follow these steps:
  1. If you do not see the XE field, do one of the following:
    • Click Show/Hide on the Standard toolbar to turn on Show/Hide.

      -or-
    • On the Tools menu, click Options. On the View tab, click to select the Hidden text check box, and then click OK.
  2. Do one of the following:
    • To edit or format an index entry, change the text inside the quotation marks. For example, {XE "Text"}.

      -or-
    • To delete an index entry, select the entire index entry field, including the braces {}, and then press DELETE.
  3. Update the index. To do this, click in the left margin of the document next to the index, and then press F9.
NOTE: Do not modify or delete index entries in the finished index; otherwise, the next time you rebuild the index, your changes will be lost.

How to Create Multiple Indexes in a Document

  1. Mark the index entries in your document.
  2. Create a bookmark for the section that you want to create an index for. To create a bookmark, follow these steps:
    1. Select the text that you want in the section.
    2. On the Insert menu, click Bookmark.
    3. Under Bookmark name, type or select a name.
    4. Click Add.
  3. Click where you want to insert the index.
  4. On the Insert menu, click Field.
  5. In the Categories box, click Index and Tables. In the Field names box, click Index.
  6. Click Options.
  7. In the Switches box, click \b. Click Add to Field.
  8. In the Field codes box, click after \b and type the name of the bookmark that you created in step 2.

    For example, if you created a bookmark named "index1," the Field codes box should contain the following text:
    INDEX \b index1
  9. Click OK twice.
  10. Repeat steps 2 through 9 for each index that you want to create.

How to Use a Concordance File and AutoMark Index Entries

Use this method when you know which words you want to index and when you want to index all those words in the document at once.
  1. On the File menu, click New. Click the General tab, select Blank Document, and then click OK.
  2. Create a two-column table. To do this, point to Insert on the Table menu, and then click Table. In the Number of Columns box, type or select 2, and then click OK.
  3. In the first column, enter the text that you want Word to search for and mark as an index entry. Make sure to enter the text exactly as it appears in the document. Press the TAB key.
  4. In the second column, type the index entry for the text in the first column, and then press the TAB key.

    NOTE: If you want to create a subentry, type the main entry followed by a colon (:) and then the subentry, similar to this:
    Dog:Labrador
  5. Repeat steps 3 and 4 for each index reference and entry.
  6. Save and close the concordance file.
  7. Use the concordance file to automatically mark the index entries in your document. To do this, follow these steps:
    1. Open the document that you want to index.
    2. On the Insert menu, click Index and Tables, and then click the Index tab.
    3. Click AutoMark.
    4. In the File name box, enter the name of the concordance file that you want to use.
    5. Click Open.
Word searches through the document for each exact occurrence of text in the first column of the concordance file, and then Word uses the text in the second column as the index entry. Word marks only the first occurrence of an entry in each paragraph.

NOTES:
  • Word inserts each marked index entry as an XE (Index Entry) field in hidden text format. If you do not see the XE field, click Show/Hide on the Standard toolbar.
  • To make sure that Word marks all the text that you want to index, list all forms of the text that you want to search for. For example, type erupt, erupting, and eruption in three separate cells in the left column, and then type volcanoes in the matching cells in the right column.
  • To speed up the creation of a concordance file, first open both the concordance file and the document that you want to index. To see both documents at once, click Arrange All on the Window menu. Then copy the text that you want to index from the document into the first column of the concordance file.

Troubleshooting

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
212011 WD2000: TOC or Index Starts with No Number for Heading 1 Style
211333 WD2000: Some Menu Commands Unavailable (Document Protection)
212051 WD2000: Mark All Button Unavailable in Mark Index Entry Box
212083 WD2000: Word Does Not Include Page Ranges in an Index
220425 WD2000: Index Is Updated Incorrectly with Modified Page Numbering

Properties

Article ID: 260833 - Last Review: December 6, 2000 - Revision: 1.0
APPLIES TO
  • Microsoft Word 2000 Standard Edition
Keywords: 
kbinfo KB260833

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com