Ntbtlog.txt File Not Written When Boot Logging Is Enabled

Article translations Article translations
Article ID: 275735 - View products that this article applies to.
This article was previously published under Q275735
Expand all | Collapse all

SYMPTOMS

After you enable boot logging to troubleshoot Windows 2000 startup issues, The Ntbtlog.txt file may not be written.

CAUSE

If the computer stops responding (hangs) before Session Manager (Smss.exe) is initialized, the log file is not created because data cannot be committed from the registry to the file.

MORE INFORMATION

Session Manager is initialized by the System process and occurs while the "Please wait" screen is displayed, before the appearance of the "Welcome to Windows" screen (the logon dialog box). The Ntbtlog.txt file is written while the computer displays "Preparing network connections."

The Safe Mode, Safe Mode with Networking, Safe Mode with Command Prompt, and Enable Boot Logging options all create a boot log that lists all of the drivers and services that are loaded (or not loaded). The file is saved in the %SystemRoot% folder.

The Smss.exe process is responsible for:
  • Creating LPC port objects and threads for client requests (for example, loading a new subsystem).
  • Defining symbolic links for MS-DOS-based devices (for example, COM1 and LPT1).
  • Initializing Terminal Services if it is installed.
  • Running any programs that are defined in the HKLM\System\CCS\Control\SessionManager\Bootexecute registry location.
  • Performing any delayed file-rename operations or pending file deletions.
  • Opening known DLLs.
  • Creating additional paging files if any are specified.
  • Initializing the registry.
  • Creating the system environment variables.
  • Loading the Kernel-mode portion of the Win32k subsystem.
  • Starting subsystem processes.
  • Starting the logon process (Winlogon.exe).
  • Creating other LPC ports for debug messages.
The Ntbtlog.txt file is first written to the registry and then flushed to the disk. This is done so that nothing is written to the hard disk until Autocheck and Chkdsk have finished running.

Properties

Article ID: 275735 - Last Review: March 1, 2007 - Revision: 3.2
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
Keywords: 
kbenv kbprb KB275735

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com