Article ID: 298831 - Last Review: February 21, 2007 - Revision: 3.5

Server for NIS Cannot Process Commas in User's Display Name

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
This article was previously published under Q298831
Expand all | Collapse all

SYMPTOMS

With Windows 2000, new users are added by using the Active Directory Users and Computers tool. The display name field for a user is normally formatted as "FirstName LastName". However, depending on what other software you have installed, the display names may be formatted as "LastName, Firstname" . Note that Microsoft Exchange is an example of a program that may format the displays differently.

If the DC also has the SFU Server for NIS component installed, a UNIX Attributes tab for each user is visible in Active Directory Users and Computers. You use the UNIX Attributes tab to set UNIX attributes like NIS domain, UID, GID, and other settings. If you select the UNIX Attributes tab while you are modifying a user's attributes, and the user has a comma in their display name, when you try to close the UNIX Attributes properties, you receive the following error message:
Title = UNIX Attributes
Msg = Duplicate UID.
Assign a unique UID.

CAUSE

This problem can occur because the SFU code that process the UNIX Attributes properties uses a comma as a delimiter.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date        Time     Version        Size       File name     Platform
   ---------------------------------------------------------------------
   05/16/2001  03:45p   5.2000.328.18  1,603,584  Nis2ad.exe    Intel
   05/16/2001  03:45p   5.2000.328.18  1,455,104  Nisadmin.exe  Intel
   05/16/2001  03:45p   5.2000.328.18  1,644,544  Nisctrl.dll   Intel
   05/16/2001  03:45p   5.2000.328.18  1,603,584  Nismap.exe    Intel
   05/16/2001  05:24p   5.2000.328.18     81,920  Nisprop.dll   Intel
   05/16/2001  03:20p   5.2000.328.18    129,536  Nissvc.exe    Intel
				

WORKAROUND

To work around this problem, do not use a comma in display names.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

APPLIES TO
  • Microsoft Windows 2000 Server SP1
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbenv kbprb kbqfe kbui KB298831
 

Article Translations