Files from an FTP site may download into folders that you did not designate in Windows 2000 or in Windows XP

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Article ID: 810790 - View products that this article applies to.
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SYMPTOMS

When you download a file from an FTP site, by using the FTP command-line client or by clicking a link on a Web page, the downloaded file may not download into the folder that you selected on a computer that is running Microsoft Windows 2000 or Microsoft Windows XP. The file may also replace existing files on the computer.

CAUSE

This problem occurs when the FTP server delivers files that have certain characters in the file name. If the manipulated file name matches a folder location on your hard disk, the file may be downloaded to that location, especially if you select the Windows Desktop as the download folder for the file.

This problem may be exploited by a malicious FTP server to deliver software that replaces specific system files and programs.

RESOLUTION

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Nov-2002  23:51  6.0.2800.1143     230,400  Msieftp.dll      
			
Windows XP, 64-Bit Edition
   Date         Time   Version            Size    File name     Platform
   ---------------------------------------------------------------------
   20-Nov-2002  23:51  6.0.2800.1143     581,120  Msieftp.dll   IA-64
   20-Nov-2002  23:04  6.0.2800.1143     230,400  Wmsieftp.dll  x86
			

Windows 2000 hotfix information

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
    Date         Time   Version             Size   File name
   -----------------------------------------------------------
    26-Nov-2002  17:11  5.0.3502.6137     246,544  Msieftp.dll       
			

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server product

Properties

Article ID: 810790 - Last Review: October 26, 2006 - Revision: 2.5
APPLIES TO
  • Microsoft Windows XP 64-Bit Edition Version 2002
  • Microsoft Windows XP 64-Bit Edition Version 2003
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbftp kbdownload kbqfe kbfix kbbug KB810790

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