Stop 0x50 Error Occurs in SrvCompleteExecuteTransaction When You Use the XCOPY Command to Copy Files from an OS/2 File Share

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Article ID: 811775 - View products that this article applies to.
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SYMPTOMS

When you use the xcopy command to copy a file from an OS/2 network share to a Windows 2000-based computer, you receive the following Stop error:
STOP 0x00000050 (0xb6c7d000 0x00000000 0x00000000 0x00000000) in SrvCompleteExecuteTransaction

CAUSE

This problem occurs when one or more of the files that you are copying have the OS/2 extended attributes assigned to them.

RESOLUTION

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP x86
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Dec-2002  16:36  5.1.2600.1154     322,048  Srv.sys
				
Windows XP IA-64
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Dec-2002  16:36  5.1.2600.1154   1,140,480  Srv.sys
				

Windows 2000

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Dec-2002  16:09  5.0.2195.6154     250,640  Localspl.dll     
   20-Dec-2002  16:09  5.0.2195.6023     381,712  Printui.dll      
   18-Dec-2002  18:50  5.0.2195.6159     155,136  Sp3res.dll       
   20-Dec-2002  16:09  5.0.2195.6047      79,632  Spoolss.dll      
   20-Dec-2002  16:09  5.0.2195.6160     237,712  Srv.sys
   20-Dec-2002  16:09  5.0.2195.6110      74,000  Srvsvc.dll       
   20-Dec-2002  16:09  5.0.2195.6044      84,752  Win32spl.dll     
   20-Dec-2002  16:09  5.0.2195.6032     114,448  Winspool.drv
   20-Dec-2002  16:09  5.0.2195.6112      55,056  Wlnotify.dll     
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP

This problem was first corrected in Microsoft Windows XP Service Pack 2.

Windows 2000

This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 811775 - Last Review: February 27, 2014 - Revision: 3.7
APPLIES TO
  • Microsoft Windows XP 64-Bit Edition Version 2002 SP1
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbwinnt400presp7fix kbwin2ksp4fix kbqfe kbwin2000presp4fix kbfix kbbug KB811775

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