Hardware Profile Shows Incorrect Docking Status for Portable Computer

Article translations Article translations
Article ID: 821161 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

On your Windows XP Service Pack 1 (SP1)-based system, one or both of the following symptoms may occur:
  • When you start your undocked portable computer, your hardware profile may show the computer as docked.
  • When you hot-dock your portable computer, or when you shut down and then restart your docked portable computer, your hardware profile may show the computer as undocked.
Note To view your hardware profile, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Click Performance and Maintenance.

    Note This step presumes that you are viewing Control Panel in Category View. In Classic View, go right to step 3.
  3. Click System.
  4. Click the Hardware tab, and then click Hardware Profiles.
  5. In the Hardware Profiles dialog box, click the profile that appears in the Available hardware profile box, and then click Properties.

CAUSE

This behavior may occur when the IBM Power Management Service is running.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   15-Jul-2003  00:42  5.3.18.6          25,600  Xpsp1hfm.exe     
   22-Jul-2003  00:55  5.1.2600.117   1,848,832  Ntkrnlmp.exe     
   22-Jul-2003  00:56  5.1.2600.117   1,902,464  Ntkrnlpa.exe     
   22-Jul-2003  00:56  5.1.2600.117   1,875,456  Ntkrpamp.exe     
   22-Jul-2003  00:55  5.1.2600.117   1,880,320  Ntoskrnl.exe     
   22-Jul-2003  01:57  5.1.2600.1251  1,896,960  Ntkrnlmp.exe     
   22-Jul-2003  01:58  5.1.2600.1251  1,952,640  Ntkrnlpa.exe     
   22-Jul-2003  01:58  5.1.2600.1251  1,924,608  Ntkrpamp.exe     
   22-Jul-2003  01:57  5.1.2600.1251  1,929,344  Ntoskrnl.exe     				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 821161 - Last Review: February 27, 2014 - Revision: 3.2
APPLIES TO
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB821161

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com