You Receive Error 1913 When You Install a Program on Windows XP

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Article ID: 823116 - View products that this article applies to.
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SYMPTOMS

When you try to install a program that uses the Microsoft Windows Installer, you may receive an error message that is similar to the following:
Error 1913: Could not update the ini file \\Server_name\Path\File_name.ini.

Verify that the file exists and that you can access it.

CAUSE

This problem may occur when the Everyone group does not have permissions on the shared folder that contains the \\Server_name\Path\File_name.ini file.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

X86 Update

   Date         Time   Version        Size       File name
   -------------------------------------------------------
   30-Jun-2003  10:59  2.0.2600.1221  2,017,792  Msi.dll
				

IA-64 Update

   Date         Time   Version        Size       File name
   ------------------------------------------------------------
   30-Jun-2003  10:59  2.0.2600.1221  6,101,504  Msi.dll   IA-64
   11-May-2003  19:05  2.0.2600.1221  2,017,792  Wmsi.dll  X86
				

WORKAROUND

To work around this problem, perform both of the following tasks:
  • Set the permissions of the Everyone group for the shared folder to Change. To set these permissions, follow these steps:
    1. In Windows Explorer, right-click the shared folder, and then click Properties.
    2. On the Sharing tab, click Permissions.
    3. With the Everyone group selected, click to select the Allow check box for the Change permission.
  • Set the NTFS file system permissions for the shared folder to Modify. To set these permissions, follow these steps:
    1. In Windows Explorer, right-click the shared folder and then click Properties.
    2. On the Security tab, select the Everyone group, and then click to select the Allow check box for the Modify permission.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Properties

Article ID: 823116 - Last Review: August 29, 2007 - Revision: 3.1
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB823116

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