Client Programs Stop Responding While They Wait for File Locking to Occur

Article translations Article translations
Article ID: 823272 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

In a client-server environment, where multiple client programs perform file locking on a data file that is located on the file server, all the client programs may stop responding (hang).

CAUSE

This problem may occur if the client program performs a particular sequence of lock requests on the data file, and as a result, the client program that is granted the lock never receives the lock. This problem occurs because of a redirector opportunistic locking issue.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
	Windows 2000
	
	   Date         Time   Version        Size     File name
	   ------------------------------------------------------
	   20-Jun-2003  03:29  5.0.2195.6760  407,792  Mrxsmb.sys
	   20-Jun-2003  03:29  5.0.2195.6760  169,520  Rdbss.sys
	
	Windows XP
	
	   Date         Time    Version       Size     File name
	   ------------------------------------------------------
          26-Jun-2003  12:00  5.1.2600.1239   92,160  Cscdll.dll
	   24-Jun-2003  03:11  5.1.2600.1239  401,920  Mrxsmb.sys
	   24-Jun-2003  03:11  5.1.2600.1239  156,160  Rdbss.sys

WORKAROUND

To work around this problem, disable opportunistic locking either on all the client computers or on the file server computer. For additional information about how to disable opportunistic locking, click the following article number to view the article in the Microsoft Knowledge Base:
129202 PC Ext: Explanation of Opportunistic Locking on Windows NT

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New Naming Schema for Microsoft Windows Hotfix Packages

Properties

Article ID: 823272 - Last Review: June 5, 2007 - Revision: 3.6
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbwinxppresp2fix kbbug kbfix kbqfe kbwin2000presp5fix KB823272

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com