Improved reporting of Event ID 61 event messages to identify a print queue or a print device

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Article ID: 824339 - View products that this article applies to.
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This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy.
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SYMPTOMS

When you receive a print Event ID 61 event message, you may not be able to determine which print queue, print device, or specific error occurred to troubleshoot the problem. For example, you may receive an Event ID 61 event message that is similar to the following event message in the system log in Event Viewer:

Event Type: Error
Event Source: Print Event Category: None
Event ID: 61
Date: date
Time: time
User: user code
Computer: PRINTSERVER
Description: The document Spreadsheet.xls owned by USER25 failed to print. Win32 error code returned by the print processor: 3003 (0xbbb).ERROR_SPL_NO_STARTDOC

CAUSE

This problem occurs because the error that the underlying component reported was overwritten. Therefore, only the last error was reported. For example, the following Win32 error codes may have been reported:
  • ERROR_SPL_NO_STARTDOC (3003)

    This error code means that a StartDocPrinter call was not issued. You receive this error code when the print spooler cannot send data to the port. The print job is marked as "error printing." In this scenario, the print spooler repeatedly tries to send the data until the user cancels the job. The error that the port monitor component returns is overwritten when the user cancels the print job.
  • ERROR_SUCCESS (0)

    This error code means that the operation completed successfully. You receive this error code when an underlying component such as graphics device interface (GDI) returns a failure but does not set the last error.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must be running Microsoft Windows 2000 Service Pack 3 (SP3) or later to install this hotfix.

For additional information about how to obtain the latest Windows 2000 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows 2000
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Feb-2004  02:39  5.0.2195.6824      42,256  Basesrv.dll      
   21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe          
   17-Feb-2004  02:39  0.2.0.1           138,000  Faxui.dll        
   17-Feb-2004  02:39  5.0.2195.6897     222,992  Gdi32.dll        
   17-Feb-2004  02:39  5.0.2195.6897     711,952  Kernel32.dll     
   17-Feb-2004  02:39  5.0.2195.6895     252,688  Localspl.dll     
   17-Feb-2004  02:39  5.0.2195.6824      54,032  Mpr.dll          
   17-Feb-2004  02:39  5.0.2195.6895     334,608  Msgina.dll       
   17-Feb-2004  02:39  5.0.2195.6892      90,264  Rdpwd.sys
   05-Feb-2004  20:18  5.0.2195.6896   5,869,056  Sp3res.dll       
   17-Feb-2004  02:39  5.0.2195.6876      80,144  Spoolss.dll      
   17-Feb-2004  02:39  5.0.2195.6891     380,688  User32.dll       
   17-Feb-2004  02:39  5.0.2195.6891     391,952  Userenv.dll      
   12-Feb-2004  00:53  5.0.2195.6897   1,630,256  Win32k.sys
   17-Feb-2004  02:39  5.0.2195.6824      87,312  Win32spl.dll     
   11-Nov-2003  00:29  5.0.2195.6873     182,032  Winlogon.exe     
   17-Feb-2004  02:39  5.0.2195.6884     243,984  Winsrv.dll       
   17-Feb-2004  02:39  5.0.2195.6897     711,952  Kernel32.dll     
   12-Feb-2004  00:53  5.0.2195.6897   1,630,256  Win32k.sys
   17-Feb-2004  02:39  5.0.2195.6884     243,984  Winsrv.dll       
Windows XP
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   20-Feb-2004  07:01  5.1.2600.1346  257,536  Gdi32.dll
   20-Feb-2004  07:01  5.1.2600.1346  297,984  Localspl.dll
   20-Feb-2004  07:01  5.1.2600.1331   36,864  Mf3216.dll
   09-Jan-2004  10:46  5.4.1.0          6,656  Spmsg.dll
   12-Feb-2004  11:43  5.1.2600.1344  586,752  Xpsp2res.dll
   09-Jan-2004  17:11  5.4.1.0        140,800  Spuninst.exe  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you install this hotfix, you receive the following Event ID 6161 event message:

Event Type: Error
Event Source: Print
Event Category: None
Event ID: 6161
Date: date
Time: time
User: user code
Computer: PRINTSERVER
Description: The document PCL5c Metafile Document owned by username failed to print on printer Printername. Data type: NT EMF 1.008. Size of the spool file in bytes: 0. Number of bytes printed: 0. Total number of pages in the document: 0. Number of pages printed: 0. Client machine: computername. Win32 error code returned by the print processor: 259.

The event message more precisely specifies the actual problem after you install the hotfix. The event message may report one of the following errors:
  • ERROR_NOT_CONNECTED (2250)

    This error code means that this network connection does not exist. You may receive this error code when the spooler cannot contact the network printer device. You must troubleshoot the connectivity.
  • ERROR_NOT_ENOUGH_MEMORY (8)

    This error code means that the computer was not able to allocate memory. Frequently, you can resolve this problem by increasing the page file size.
  • ERROR_NO_MORE_ITEMS (259)

    This error code means that no more data is available. You may receive this error code if a program or a printer driver component sends an incomplete spool file to the print spooler on the print server. Therefore, the file does not print. Frequently, you can resolve this problem by installing the driver from the operating system CD.
  • ERROR_INVALID_PARAMETER (87)

    This error code means that the parameter is not valid. This error is difficult to diagnose unless you reproduce the problem. Frequently, you can resolve this problem by installing the driver from the operating system CD.
  • ERROR_SUCCESS (0)

    This error code means that the operation completed successfully. You may receive this error code if an underlying component such as GDI returns a failure but does not set the last error. This error is difficult to diagnose unless you reproduce the problem. Frequently, you can resolve this problem by installing the driver from the operating system CD.
For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 824339 - Last Review: October 26, 2006 - Revision: 4.6
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbeventlog kbprint kbbug kbfix kbqfe kbwin2000presp5fix KB824339

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