Cannot search for a file in a folder that is redirected to a Distributed File System

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Article ID: 825794 - View products that this article applies to.
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SYMPTOMS

When you try to search for a file in a folder that is redirected to a Distributed File System, your connection to the network may be forced offline.

CAUSE

This problem may occur if the folder you are searching is redirected by Folder Redirection to a Distributed File System (DFS), and the DFS is replicated between two domain controllers. The search uses the NetBIOS name of the shared folder, but the Multiple Universal Naming Convention Provider (MUP) processes the search request on the server. MUP does not support NetBIOS name searches.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

Date          Time    Version         Size     File name 
--------------------------------------------------------- 
12-Apr-2004   17:13   5.1.2600.1515  92,160    Cscdll.dll 
12-Apr-2004   17:03   5.1.2600.1515 420,608    Mrxsmb.sys 
12-Apr-2004   17:03   5.1.2600.1515 104,704    Mup.sys 
12-Apr-2004   17:03   5.1.2600.1515 166,016    Rdbss.sys  

				

Windows XP, 64-Bit Edition

Date            Time     Version             Size   File name 
-------------------------------------------------------------------- 
12-Apr-2004     08:15    5.1.2600.1515     236,544  Cscdll.dll IA-64 
10-Apr-2004     16:35    5.1.2600.1515   1,276,416  Mrxsmb.sys 
10-Apr-2004     16:35    5.1.2600.1515     354,176  Mup.sys 
10-Apr-2004     16:35    5.1.2600.1515     495,616  Rdbss.sys 
12-Apr-2004     08:13    5.1.2600.1515      92,160  Wcscdll.dll x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Properties

Article ID: 825794 - Last Review: August 29, 2007 - Revision: 4.1
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB825794

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