Article ID: 837968 - Last Review: October 25, 2007 - Revision: 2.7

Duplicate users may appear in the global address list after you configure the Exchange Server 2003 Active Directory Connector

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SYMPTOMS

Duplicate users may appear in the Exchange global address list after you configure the Microsoft Exchange Server 2003 Active Directory Connector (ADC). This problem occurs after you configure the ADC to do the following:
  • To replicate information from Microsoft Exchange Server 5.5 to the Active Directory directory service
  • To replicate information from the Active Directory directory service to the Exchange Server 5.5 directory
Additionally, one or more events that are similar to the following are logged in the Application event log on the computer that is running the ADC service.

Note Some of the following events use the same event ID number, but the description in the event is different.

Event 8020

Event ID: 8020
Event Type: Warning
Event Category: LDAP Operations
Event Source: MSADC
Description: LDAP Search of directory Directory name at base 'cn=Recipients,cn=Recipients,ou=Organizational unit,o=Organization' using filter '(objectclass=*)' was unsuccessful. Directory returned the LDAP error:[0x51] Server Down.

Event 8024

Event ID: 8024
Event Type: Error
Event Category: LDAP Operations
Event Source: MSADC
Description: LDAP Search Initial Page on directory Directory name at base 'o=Organization' with filter '(msExchADCGlobalNames=NT5:GUID*)' was unsuccessful. Directory returned the LDAP error:[0x51] Server Down.

Event 8024

Event ID: 8024
Event Type: Error
Event Category: LDAP Operations
Event Source: MSADC
Description: LDAP Search Initial Page on directory Directory name at base 'o=Organization' with filter '(distinguishedName=cn=Recipients,ou=Organizational unit,o=Organization)' was unsuccessful. Directory returned the LDAP error:[0x51] Server Down.

Event 8270

Event ID: 8270
Event Type: Error
Event Category: LDAP Operations
Event Source: MSADC
Description: LDAP returned the error [44] Already Exists when importing the transaction dn: cn=User name,cn=Recipients,cn=Recipients,ou=Organizational unit,o=Organization changetype: Add admin-display-name:User name distinguishedname:OU=User name,cn=Recipients,cn=Recipients,ou=Organizational unit,o=Organization createtimestamp:20030327164659.0Z objectguid:GUID replication-signature:GUID msexchadcglobalnames:forest:o=Organization GUID : EX5:cn=User name,cn=Recipients,ou=Organizational unit,o=Organization:container$to... : NT5:GUID : FOREST:GUID container-info:-2147483647 ReplicatedObjectVersion:0

Event 8271

Event ID: 8271
Event Type: Information
Event Category: Replication
Event Source: MSADC
Description: Successfully replicated the object 'OU=Recipients,OU= Organizational unit,OU=Recipients,DC= corp,DC=contoso ,DC=com' to object 'cn=Recipients,cn=Recipients,ou=Organizational unit,o=Organization'.

Event 8271

Event ID: 8271
Event Type: Information
Event Category: Replication
Event Source: MSADC
Description: Successfully replicated the object 'CN=User,OU=User name,OU=Recipients,OU=Organizational unit,OU=Recipients,DC=corp,DC=contoso,DC=com' to object 'cn=User name,cn=Recipients,cn=Recipients,ou=Organizational unit,o=Organization'. (Connection Agreement 'Connection agreement name' #1264)

CAUSE

This problem occurs if Lightweight Directory Access Protocol (LDAP) errors occur during replication between Active Directory and the Exchange Server 5.5 directory. The ADC creates duplicate objects in the Exchange Server 5.5 directory when the following conditions are true:
  • LDAP connectivity is lost when the ADC searches for objects in the Exchange Server 5.5 directory.
  • LDAP connectivity is restored when the ADC tries to create new contacts because of the unsuccessful search for a matching object in the Exchange Server 5.5 directory.

    Note The unsuccessful search for a matching object in the Exchange Server 5.5 directory occurs because of the loss of LDAP connectivity.
The Exchange 2003 ADC interprets the following kinds of search results as equivalent:
  • Unsuccessful searches that occur because of a loss of LDAP connectivity
  • Successful searches that do not find a matching object in the Exchange Server 5.5 directory

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993  (http://support.microsoft.com/kb/836993/ ) How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, the Active Directory Connector service is automatically stopped and then restarted when you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Jun-2004  00:58  6.5.7232.6        697,344  Adc.exe    

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
837165  (http://support.microsoft.com/kb/837165/ ) Duplicate users occasionally appear in the global address list in Exchange 2000 Server

APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbqfe kbexchdirectory kbfix kbbug KB837968
 

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