You receive an access violation in Internet Explorer 6 SP1 when you use a custom Web-based program over SSL

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Article ID: 843613 - View products that this article applies to.
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SYMPTOMS

When you use a custom Secure Sockets Layer (SSL) Web-based program, you may receive a page fault or an access violation in Microsoft Internet Explorer 6 Service Pack 1 (SP1). Additionally, Internet Explorer 6 SP1 may crash when you install security updates from Microsoft Windows Update on a Microsoft Windows XP Service Pack 1 (SP1)-based computer.

CAUSE

This problem occurs because of a buffer allocation failure in the Wininet.dll file. This problem has the following associated call stack:
 06d8fe8c 70247b6c 060d4fc0 060d5e84 00000ec4 NTDLL!RtlMoveMemory+0x1b
 06d8fea0 70247bdc 032aaad8 70247c45 000001bc wininet!DBLBUFFER::CompressInputBufferUsage+0x18 
 06d8fea8 70247c45 000001bc 70246443 000001bc wininet!DBLBUFFER::GetInputBufferRemaining+0xf 
 06d8feb0 70246443 000001bc 032d1aa0 060f4810 wininet!DBLBUFFER::ResizeBufferIfNeeded+0x8 
 06d8ff08 70246f84 060f48dc 061912f8 060f48a8 wininet!ICSecureSocket::DecryptData+0x11e 
 06d8ff34 7024751e 00000000 7020ff49 060f4810 wininet!ICSecureSocket::Receive_Fsm+0x1ca 
 06d8ff3c 7020ff49 060f4810 03223618 060f4810 wininet!CFsm_SecureReceive::RunSM+0x2a 
 06d8ff54 7020fef6 03223618 06d8ff8c 06d8ff80 wininet!CFsm::Run+0x37 
 06d8ff84 70c1ab2d 00000000 00000000 70bd0000 wininet!CFsm::RunWorkItem+0x77 
 06d8ffac 70c1acdf 00000000 7c4e987c 00000000 shlwapi!CThreadPool::Worker+0x3e 
 06d8ffb4 7c4e987c 00000000 00000000 00000000 shlwapi!CThreadPool::WorkerThread+0x30 
 06d8ffec 00000000 70c1acaf 00000000 00000000 KERNEL32!BaseThreadStart+0x52

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version          Size      File name
   -----------------------------------------------------------
   14-Jun-2004  22:42   6.0.2800.1448    572,416   Wininet.dll
				

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

Properties

Article ID: 843613 - Last Review: November 15, 2007 - Revision: 1.7
APPLIES TO
  • Microsoft Internet Explorer 6.0 SP1, when used with:
    • the operating system: Microsoft Windows XP Professional SP1
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbie600sp2fix kbie600presp2fix kbfix kbbug KB843613

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