SOURCENEXT VirusSecurity2004 real-time monitor does not work correctly on a Windows XP Service Pack 2-based computer

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Article ID: 870900
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Symptoms

When you use the third-party SOURCENEXT Corporation VirusSecurity2004 program on a computer that is running Microsoft Windows XP Service Pack 2 (SP2), the real-time monitor does not work correctly. The Real Time Scanner Service does not start.

Cause

This problem occurs because the K7Sentry device driver cannot load correctly. The K7Sentry device driver tries to load or "hook" the IoCreateFile kernel-mode routine. In Windows XP SP2, changes were made to the IoCreateFile kernel-mode routine. Because the address of the IoCreateFile kernel-mode routine is different in Windows XP SP2, the K7sentry.sys driver cannot locate the routine.

Notes
  • The K7Sentry device driver is named K7sentry.sys.
  • Windows XP does not support drivers that try to hook kernel-mode routines instead of registering for file system notifications.

Resolution

To resolve this problem, we recommend that you contact SOURCENEXT Corporation for more information about how to obtain a version of the K7Sentry device driver that is compatible with Windows XP SP2. For more information about how to contact SOURCENEXT Corporation, visit the following SOURCENEXT Corporation Web site:
http://www.sourcenext.com
Note This Web site is Japanese. At the time of the publication of this article, there are no known English SOURCENEXT Web sites.

More information

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Properties

Article ID: 870900 - Last Review: June 20, 2014 - Revision: 4.0
Keywords: 
kbvirus kberrmsg kbsecurity kb3rdparty kbtshoot kbprb KB870900

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