Article ID: 889071 - Last Review: July 24, 2007 - Revision: 3.4

Microsoft Operations Manager 2005 agent alerts are not processed when the Ignore Missing Heartbeats option is enabled

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

Assume that you have selected a computer under Agent-managed computers or under Agentless managed computers in the Microsoft Operations Manager (MOM) 2005 Administrator Console. If you turn on the Ignore Missing Heartbeats option, the MOM Management Server does not process any alerts that are received from the MOM agent. Additionally, the alerts are not added to the MOM OnePoint database.

CAUSE

When the Ignore Missing Heartbeats option is enabled, the MOM 2005 agent generates alerts as usual. However, when the Management Server receives the alert for processing, the alert is discarded.

When the Ignore Missing Heartbeats option is enabled, the MOM 2005 agent goes into maintenance mode. Any alerts that are generated by the MOM agent are not processed or added to the MOM OnePoint database.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Operations Manager 2005. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
905416  (http://support.microsoft.com/kb/905416/ ) How to obtain the latest Microsoft Operations Manager 2005 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Dec-2004  17:11  6.0.2900.2180     117,480  Mom2005-rtm-kb889071-x86-enu.exe  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Operations Manager 2005 Service Pack 1.

MORE INFORMATION

Installation instructions

Note We recommend that you back up the MOM OnePoint database before you install this hotfix.

Install the hotfix on a server that is hosting the MOM OnePoint database. The server can be a MOM Management Server or a stand-alone server. This hotfix enables the MOM Management Server to process alerts that are received from MOM agent computers that have the Ignore Missing Heartbeats option turned on.

When you install this hotfix, only alerts generated by the following event processing rules are ignored:
  • MOM Agent heartbeat failure - idProcessrule = B2FC934C-BE4F-4871-AFB4-E46E6A63F8DC - RulePath = Rule Groups\Microsoft Operations Manager\Operations Manager 2005\Server\Event Rules
  • MOM Agentless heartbeat failure - idProcessrule = 1BA79160-621C-4035-9520-0A093C5F2F32 - RulePath = Rule Groups\Microsoft Operations Manager\Operations Manager 2005\Server\Event Rules
To install this hotfix, follow these steps:
  1. Copy the MOM2005-RTM-KB889071X86-ENU.exe file to a local folder or to a network shared folder that can be accessed by the MOM Management Server.
  2. Log on to the server that is hosting the MOM OnePoint database by using an account that has administrative credentials.
  3. Stop the MOM service on the MOM Management Server. If there are multiple Management Servers in the MOM configuration group, you must also stop the MOM service on the other MOM Management servers. To do this, follow these steps:
    1. On the MOM Management Server, click Start, point to Programs, click Administrative Tools, and then click Services.
    2. In the Services snap-in, right-click MOM service, and then click Stop.
  4. Locate and double-click the MOM2005-RTM-KB889071X86-ENU.exe file.
  5. In the MOM2005-RTM-KB889071X86-ENU.EXE dialog box, click Yes to accept the License Agreement dialog box.
  6. In the MOM Update dialog box, click to select the instance of Microsoft SQL Server that is hosting the MOM OnePoint database, and then click Update to apply the changes to the MOM OnePoint database.

    Note You can run the MOM2005-RTM-KB889071X86-ENU.exe file from Windows Explorer or at a command prompt.
For more information about other problems that are resolved by Microsoft Operations Manager 2005 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
905420  (http://support.microsoft.com/kb/905420/ ) List of bugs that are fixed in Microsoft Operations Manager 2005 service packs
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Operations Manager (MOM) 2005
Keywords: 
kbautohotfix kbqfe kbhotfixserver atdownload kbgetsp kbbug kbfix KB889071
 

Article Translations

 

Related Support Centers