Article ID: 906154 - Last Review: October 25, 2007 - Revision: 1.3

The Microsoft Exchange System Attendant service may not come online if the RootVer registry value is invalid on a server that is running Exchange Server 2003

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SYMPTOMS

The Microsoft Exchange System Attendant service may not come online on a server that is running Microsoft Exchange Server 2003 in a Microsoft Windows 2000 active/passive cluster. Additionally, events that are similar to the following may be logged in the Application log:
Event Type: Error
Event Source: MSExchangeSA
Event Category:
Event ID: 1031
Description: One of the System Attendant's task is blocked.
Event Type: Error
Event Source: MSExchangeMU
Event Category:
Event ID: 1043
Description: Metabase Update failed to initialize enumerator of virtual server on cluster database. Error code is error 800706b5.
Event Type: Error
Event Source: MSExchangeMU
Event Category:
Event ID: 1042
Description: Metabase Update failed to read the Configuration namespace property from the domain controller. Error code is 80040a01.
Event Type: Error
Event Source: POP3SVC
Event Category:
Event ID: 1036
Description: An error occurred while starting the Microsoft Exchange POP3 Service: server instance number 1 failed to start with error 0x80040a01.
Event Type: Error
Event Source: IMAP4SVC
Event Category:
Event ID: 1036
Description: An error occurred while starting the Microsoft Exchange IMAP4 Service: server instance number 1 failed to start with error 0x80040a01.
Event Type: Error
Event Source: MSExchangeCluster
Event Category:
Event ID: 1019
Description: Exchange System Attendant: Failed to bring this resource online because of timeout.
Event Type: Error
Event Source: MSExchangeCluster
Event Category:
Event ID: 1003
Description: Exchange System Attendant: Failed to bring the resource online.
Event Type: Error
Event Source: MSExchangeCluster
Event Category:
Event ID: 1012
Description: Exchange Information Store Instance: The RPC call to the service to take the resource offline failed.
Additionally, you may experience the following symptoms when this problem occurs:
  • The Microsoft Exchange Information Store service may not start.
  • The store databases may not start.
  • The Post Office Protocol version 3 (POP3) service may not start.
  • The Internet Message Access Protocol version 4rev1 (IMAP4) service may not start.

CAUSE

This problem occurs if the RootVer registry value is invalid.

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


If the computer is running the Microsoft .NET Framework 1.1, set the RootVer registry value to 1.1.4322.0. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET
  3. Double-click the RootVer value, type 1.1.4322.0 in the Value data box, and then click OK.
  4. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem may also occur in the following scenarios:
  • When you remove Active Directory from the domain controller, the ASPNET security account is removed. Therefore, the metabase update service may not be able to start. Additionally, several events that are mentioned in the "Symptoms" section may be logged in the Application log. To resolve this problem, reinstall Exchange Server 2003.
  • When there is a permissions issue, several events that are mentioned in the "Symptoms" section may be logged in the Application log. To resolve this problem, run the Exchange Server 2003 Setup program by using the /domainprep switch, as in the following example:
    drive:\setup\i386\setup /domainprep

APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Keywords: 
kbexchcluster kbprb KB906154
 

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