Error message when you try to install SQL Server 2005 in a cluster environment: "SQL Server Setup could not validate the service accounts"

Article translations Article translations
Article ID: 926621 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

You try to install Microsoft SQL Server 2005 in a cluster environment that has two cluster nodes. When you run SQL Server Setup on the first node, the setup process on the second node fails. Additionally, you receive the following error message on the first node:
SQL Server Setup could not validate the service accounts. Either the service accounts have not been provided for all of the services being installed, or the specified username or password is incorrect. For each service, specify a valid username, password, and domain, or specify a built-in system account.
This problem may occur if the following conditions are true:
  • In the Setup program, you specify a domain account for the SQL Server service startup account.
  • The password for the domain account contains quotation marks.

CAUSE

This problem occurs because the password for the domain account is incorrectly changed on the second node during the installation. In the password, one quotation mark is incorrectly changed to two quotation marks.

WORKAROUND

To work around this problem, do not use quotation marks in the password for the SQL Server service startup account when you install SQL Server 2005 in a cluster environment.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 926621 - Last Review: November 20, 2007 - Revision: 1.2
APPLIES TO
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Enterprise Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Standard X64 Edition
  • Microsoft SQL Server 2005 Standard Edition for Itanium-based Systems
  • Microsoft SQL Server 2005 Enterprise X64 Edition
  • Microsoft SQL Server 2005 Enterprise Edition for Itanium-based Systems
Keywords: 
kbexpertiseadvanced kbtshoot kbsql2005setup kbprb KB926621

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com