Winsock error message when you use a program that tries to bind to TCP network ports on a Windows-based computer: "WSAEADDRINUSE (10048)"

Article translations Article translations
Article ID: 943710 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

When you use a program that tries to bind to TCP network ports on a Windows-based computer, you may receive the following Winsock error message:
WSAEADDRINUSE (10048) Only one usage of each socket address (protocol/network address/port) is normally permitted.
This behavior occurs if the following conditions are true:
  • Internet Connection Sharing is enabled on the computer that is running Windows.
  • The program tries to connect to TCP ports in the 5001 to 5032 range.

CAUSE

This issue occurs because the Application Layer Gateway service reserves the TCP ports in the 5001 to 5032 range.

STATUS

This behavior is by design.

WORKAROUND

To work around this behavior, stop the Application Layer Gateway service. To stop the Application Layer Gateway service, follow these steps.

Note Stop this service only if you do not have to have FTP functionality.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, type services in the Start Search box, and then press ENTER.
  2. In the results, right-click Services, and then click Run as administrator.
  3. In the Services list, right-click Application Layer Gateway Service, and then click Stop.
If you want to prevent the service starting after a restart of the computer, follow these steps:
  1. Right-click the service, and then click Properties.
  2. In the Startup type box, click Disabled, and then click OK.
  3. Exit the Services snap-in.

Properties

Article ID: 943710 - Last Review: November 8, 2007 - Revision: 1.2
APPLIES TO
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Keywords: 
kberrmsg kbwinsock kbnetwork_icsissues kbexpertiseinter kbtshoot KB943710

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com