When a Windows Vista-based computer is awakened from sleep by a magic packet, and the WakeOnLAN feature is enabled, the computer's desktop is displayed unexpectedly

Article translations Article translations
Article ID: 944529 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • A Windows Vista-based computer is awakened from sleep by a magic packet.
  • The WakeOnLAN feature is enabled on the computer.
In this scenario, the computer desktop is displayed unexpectedly.

Note For more information about magic packets, see the "More information" section.

CAUSE

This problem occurs if there is an active process when the computer enters sleep mode. For example, this problem occurs if a mouse is moved or if any key is pressed on the keyboard as the computer enters sleep mode.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

A magic packet is a standard wake-up frame that targets a specific network interface. In most cases, a wake-up frame or a magic packet enables remote access to a computer that is in a power-saving state. However, some networking protocols use these packets for other purposes. For example, routers use Address Resolution Protocol (ARP) packets to periodically confirm the presence of a computer. Such protocols do not use these packets to wake computers. However, on some networks, network traffic may mistakenly wake a remote computer. These unwanted wake-up events may occur in especially noisy environments such as enterprise networks. By default, the WakeOnLAN feature is disabled in Windows Vista.

Properties

Article ID: 944529 - Last Review: November 13, 2007 - Revision: 1.0
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Keywords: 
kbtshoot kbprb KB944529

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com