On a Windows Vista-based computer, you may be prompted for your passport credentials every time that you try to access documents on a WebDAV site from a new workspace

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Article ID: 945145 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You are running a Windows Vista-based computer.
  • You try to access a Web Distributed Authoring and Versioning (WebDAV) site that is located on a server that uses passport authentication.
In this scenario, you may be prompted for your passport credentials every time that you try to access documents on the WebDAV site from a new workspace.

This behavior occurs even after you save your passport credentials in Credential Manager.

CAUSE

Windows Vista uses Windows HTTP Services (WinHTTP) to access the WebDAV site. WinHTTP must set a specific flag to enable the key ring for passport authentication. However, when the WebDAV redirector calls WinHTTP, the redirector does not set this flag as expected. Therefore, Credential Manager cannot obtain your passport credentials.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfixes and security updates that are included in SP2 for Windows Vista Service and for Windows Server 2008

For more information about the hotfixes and the security updates that are included in SP2 for Windows Vista and for Windows Server 2008, visit the following Microsoft TechNet Web site: -
http://technet.microsoft.com/en-us/library/dd335033.aspx
Note: Currently, the list of hotfixes and security updates is available only in English.

Update information

To resolve this problem, install one of the following updates, as appropriate for your situation.

Update for Windows Vista for x86-based systems

http://www.microsoft.com/downloads/details.aspx?FamilyId=58A6B5EA-5CED-4C91-A4D6-992CF917D7F1

Update for Windows Vista for x64-based systems

http://www.microsoft.com/downloads/details.aspx?FamilyId=8A387824-FC1C-487C-BEAC-5CCE30BC34DF

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable1,78415-Nov-200714:43Not Applicable
X86_3902e43b3559ecb95012f627bd27ef51_31bf3856ad364e35_6.0.6000.20721_none_f09bc0ab2988f391.manifestNot Applicable70915-Nov-200714:43Not Applicable
X86_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.0.6000.20721_none_53b48853cfb80393.manifestNot Applicable7,29115-Nov-200714:43Not Applicable
Webclnt.dll6.0.6000.20721194,56015-Nov-200704:19x86
Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_3c03e0cfcf37d14b27e9a4fb41451e97_31bf3856ad364e35_6.0.6000.20721_none_df579715ac214a74.manifestNot Applicable1,06615-Nov-200714:43Not Applicable
Amd64_microsoft-windows-webdavredir-webclient_31bf3856ad364e35_6.0.6000.20721_none_afd323d7881574c9.manifestNot Applicable7,32115-Nov-200714:46Not Applicable
Update.mumNot Applicable2,02115-Nov-200714:43Not Applicable
Webclnt.dll6.0.6000.20721211,96815-Nov-200705:09x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 945145 - Last Review: January 29, 2008 - Revision: 2.3
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbexpertisebeginner kbfix kbqfe kbhotfixserver KB945145

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