Error message when you try to sequence a program in Microsoft SoftGrid: "SystemGuard download failed (error code 53256)"

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Article ID: 945621 - View products that this article applies to.
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SYMPTOMS

When you try to sequence a program for use with Microsoft SoftGrid, you receive the following error message:
SystemGuard download failed (error code 53256)
Additionally, the following information may be logged in the sft-seq-log.txt file:
[<date> <time> VRB VFSX] SxS: Starting SxS public-to-private assembly conversion. 
[<date> <time> ERR VFSX] SxSPrivateAssembly::LoadConfigFile : Load failed. 
[<date> <time> ERR VFSX] SxSPrivateAssembly::LoadConfigFile : Load failed. 
[<date> <time> WRN VFSX] SxSPE::parseUTF : Unsupported UTF format for file <drive>:\<ProgramName>\FileInfo.dll (format # 3). 
[<date> <time> VRB RTSK] Failed to convert public SxS assemblies. 
[<date> <time> ERR RTSK] SystemGuard download failed (error code 53256). 
[<date> <time> ERR RTSK] SystemGuard download failed (error code 53256). 
By default, this file is located in the following folder:
%ProgramFiles%\Softricity\SoftGrid Sequencer\Logs\

CAUSE

This problem may occur if the SoftGrid Sequencer component tries to parse the manifest of a .dll file that is encoded by using a character set that the SoftGrid Sequencer does not recognize. Typically, this problem occurs if the SoftGrid Sequencer tries to parse the manifest of a .dll file that is encoded by using the UCS-2 Unicode character set.

Note The UCS-2 character set is an earlier version of UTF-16.

RESOLUTION

To resolve this problem, modify the manifest that corresponds to the affected .dll file. To do this, follow these steps.

Step 1: Determine which file the SoftGrid Sequencer cannot parse

To determine which file the SoftGrid Sequencer cannot parse, follow these steps.

Note These steps are performed on the sequencing station.
  1. Open the Sft-seq-log.txt file by using any text editor such as Notepad. By default, the Sft-seq-log.txt file is located in the following folder:
    %ProgramFiles%\Softricity\SoftGrid Sequencer\Logs\
  2. Search for the text string "53256" to locate an entry that resembles the following:
    [<date> <time> ERR RTSK] SystemGuard download failed (error code 53256)
  3. Locate an entry that resembles the following. This entry appears several lines above the entry that you located in step 2.
    [<date> <time> WRN VFSX] SxSPE::parseUTF : Unsupported UTF format for file Q:\<SuiteName>\<ProgramName>\<FileName.dll> (format # 3).
    [<date> <time> VRB RTSK] Failed to convert public SxS assemblies.
The .dll file that appears in this entry represents the .dll file that the SoftGrid Sequencer cannot parse successfully.

Step 2: Modify the manifest file

Modify the manifest file to enable the SoftGrid Sequencer to parse the .dll file. To do this, you must use a resource explorer tool that can open .dll files and that can expose the various resources that the .dll file uses.

The following list contains some third-party resource explorer tools: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

To modify the manifest file, follow these steps:
  1. Use the resource explorer tool to open the .dll file with which you experience the problem.
  2. Move to the Manifest section of the .dll file, and export the Manifest section as a file. For example, save the Manifest section of the .dll file as OriginalFileName.dll.manifest.
  3. Delete the Manifest section from the .dll file, and then save the modified file as OriginalFileName.dll.
  4. Repeat steps 1 through 3 for each .dll file with which you experience the problem.
After you follow these steps, you have the following:
  • One or more modified .dll files that are named OriginalFileName.dll
  • One or more corresponding Manifest files that are named OriginalFileName.dll.manifest
Important Store these pairs of files in a safe location.

Step 3: Sequence the program

Sequence the program again. However, follow these steps when you sequence the program:
  1. Reset the sequencing computer.
  2. Start the sequencing operation. Before you click Stop Monitoring, follow these steps:
    1. Copy and paste the modified OriginalFileName.dll file or files into the folder that contains the original .dll file or files with which you experienced the problem. This action overwrites each original .dll file with the modified .dll file(s).
    2. Copy and paste the corresponding OriginalFileName.dll.manifest file or files into the folder that contained the original .dll file or files.
  3. After the modified files are pasted into the appropriate folder, click Stop Monitoring.
  4. Follow the remaining steps to finish the sequencing operation.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about sequencing in Microsoft SoftGrid, click the following article numbers to view the articles in the Microsoft Knowledge Base:
932137 Best practices to use for sequencing in Microsoft SoftGrid
939796 Prescriptive guidance for sequencing 2007 Office programs in Microsoft SoftGrid
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 945621 - Last Review: December 5, 2007 - Revision: 1.0
APPLIES TO
  • Microsoft SoftGrid for Windows Desktops
  • Microsoft SoftGrid for Terminal Services
Keywords: 
kberrmsg kbtshoot kbprb KB945621

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