How to sequence Visual Studio 2005 in Microsoft SoftGrid

Article translations Article translations
Article ID: 946343 - View products that this article applies to.
Expand all | Collapse all

On This Page

INTRODUCTION

This article describes one method that you can use to sequence Microsoft Visual Studio 2005 for use with Microsoft SoftGrid. The method that is described in this article is not the only possible method. Additionally, you may have to adapt the information in this article as appropriate for your particular environment.

MORE INFORMATION

Prerequisites

You must have the following to sequence Visual Studio 2005 for use with Microsoft SoftGrid:
  • A volume license for Visual Studio 2005
  • Visual Studio 2005 Service Pack 1 or a later version
  • Hotfix 944478 for Visual Studio 2005
  • SoftGrid 4.1 Service Pack 1 or a later version
  • The VKeyPackage.dll package that enables virtualization of Visual Studio 2005 in SoftGrid
  • Hotfix 945347 for Visual Studio 2005

Hotfix 944478

If you use Visual Studio 2005 Service Pack 1, you have to obtain hotfix 944478. This hotfix enables virtualization of Visual Studio 2005 in SoftGrid. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
944478 FIX: You cannot use Microsoft SoftGrid to virtualize Visual Studio 2005

The VKeyPackage.dll package

To obtain the VKeyPackage.dll package, contact Microsoft Customer Support Services. For a complete list of Microsoft Customer Support Services telephone numbers, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support

Hotfix 945347

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
945347 You cannot sequence Visual Studio 2005 in Microsoft SoftGrid

Obtain background information

  • Review the following article in the Microsoft Knowledge Base:
    932137 Best practices to use for sequencing in Microsoft SoftGrid
  • Review the product documentation that is included with SoftGrid. This includes the following documents:
    • Quick Start Guide
    • Sequencer Install Guide
    • Sequencer User Guide
  • Install Visual Studio 2005 to become familiar with the functionality of the program.

Prepare the environment

Sequencing Visual Studio 2005 uses lots of memory. Therefore, make sure that at least 1 gigabyte (GB) of random access memory (RAM) is allocated to the computer on which you will sequence Visual Studio.

Sequence Visual Studio 2005

  1. Start the SoftGrid Sequencer.
  2. On the File menu, click New Package.
  3. Click No when you are prompted for help.
  4. On the Tools menu, click Options.
  5. Click the Exclusion Items tab.
  6. Click New.
  7. In the Exclusion Item dialog box, type %CSIDL_WINDOWS%\Installer\$PatchCache$ in the Exclude Path box.
  8. In the Exclusion Item dialog box, click VFS in the Mapping Type list.
  9. Click OK to close the Exclusion Item dialog box.
  10. Click OK to close the Options dialog box.
  11. On the Tools menu, point to Sequencing Wizards, and then click Package Configuration. The Package Configuration Wizard starts.
  12. Click Next.
  13. In the Suite Name box, type Visual Studio 2005.
  14. In the Title field, type Visual Studio 2005, and then click Next.
  15. In the Selected Operating Systems dialog box, make sure that the appropriate operating systems are selected, and then click Finish.
  16. On the Tools menu, click Sequencing Wizards, and then click Installation. This starts the Installation Wizard.
  17. On the "Welcome to the Installation Wizard" page, click Next.
  18. On the Sequencing Parameters page, accept the default settings, and then click Next.
  19. On the "Monitor installation" page, click Begin Monitoring. Wait for the dialog box to be minimized or to display the following message:
    Monitoring started. Please begin installation.
  20. Run the Setup program for Visual Studio 2005. Use the default options for Visual Studio 2005, except for the following two items in the last window:
    • In the Product install path box, type Q:\VS2005.1.
    • On the left side, click Custom, and then click Next. In the Optional Components area, click to clear the Microsoft SQL Server 2005 Express Edition x86 check box, and then click Install.
  21. After the Setup program has finished, install Visual Studio 2005 Service Pack 1.
  22. Check for the latest updates, and then install these updates.
  23. Install hotfix 944478.
  24. Install the VKeyPackage.dll package. To do this, follow these steps:
    1. Copy the VKeyPackage.dll package to the Q:\VS2005.1\ folder.
    2. Run the following command at the command prompt:
      regsvr32 Q:\VS2005.1\VKeyPackage.dll
    3. In the dialog box that indicates that the package is registered, click OK.
  25. In the Installation Wizard, click Stop Monitoring.
  26. In the Browse for Folder dialog box, type Q:\VS2005.1 in the Select the primary directory the product was installed to box, and then click OK.

    You receive the following message:
    Downloading virtual environment
  27. Wait for the green progress bar to finish. You will receive the following message:
    Monitoring finished
    Note This will take several minutes.
  28. Click Next.
  29. On the "Additional Files to Map to the VFS" page, click Finish.

    Note It may take several seconds for the dialog box to disappear. The sequencer has not stopped responding.
  30. On the Tools menu, click Sequencing Wizards, and then click Application.
  31. On the "Welcome to the Application Wizard" page, click Next.
  32. On the Configure Applications page, view the list of applications, and then click Next.
  33. On the Launch Applications page, click Launch All.
  34. Close each application after it starts. You may receive error messages from some applications as the applications start. You can safely ignore these error messages. After all the applications have started and then shut down, the application list is displayed again. A check mark appears next to each application. Click Next.
  35. On the Sequence Package page, wait for the green progress bar in the Sequencing blocks area to finish.

    Note This will take several minutes.
  36. Click Finish when you receive the following message:
    Sequencing complete
  37. On the File menu, click Save As. Open a directory that has sufficient free space to create a directory named VS2005. This directory will hold the sequence.
  38. Change the name of the file that is being saved from Softapp.sprj to VS2005.sprj, and then click Save.

    Note It may take several minutes to save the file.
  39. Confirm that the .sft file that is generated is smaller than 4 gigabytes. If it is not, make sure that you added the %CSIDL_WINDOWS%\Installer\$PatchCache$ exclusion correctly in step 7. If you added the exclusion, you have to use the compression option in SoftGrid Sequencer to reduce the size of the sequence that you generated.

Properties

Article ID: 946343 - Last Review: November 19, 2008 - Revision: 2.0
APPLIES TO
  • Microsoft Application Virtualization for Terminal Services
  • Microsoft Application Virtualization for Windows Desktops
Keywords: 
kbhowto kbexpertiseinter kbinfo KB946343

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com