Error message when you use the Dsdbutil.exe utility or the Ntdsutil.exe utility to perform an authoritative restore of an object in Windows Server 2003: "Invalid Key %s found in DN"

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Article ID: 961071 - View products that this article applies to.
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SYMPTOMS

When you use the Dsdbutil.exe utility or the Ntdsutil.exe utility to perform an authoritative restore of an object in Windows Server 2003, you receive the following error message:
Invalid Key %s found in DN.
This problem occurs when the DN of the object contains any string except for the following relative distinguished names (also known as RDNs):
  • "DC" or "DomainComponent"
  • "CN" or "CommonName"
  • "OU" or "OrganizationalUnitName"
  • "O" or "Organization"
  • "STREET" or "StreetAddress"
  • "L" or "LocalityName"
  • "ST" or "StateOrProvinceName"
  • "C" or "CountryName"
Note A DN is a sequence of relative distinguished names that are connected by commas.

For example, you have an object in an Active Directory Application Mode (ADAM) database and the DN of this object contains the UID relative distinguished name. When you use the Dsdbutil.exe utility to perform an authoritative restore for this object, you receive the following error message:
Invalid key "uid" found in DN.
Authoritative Restore failed.
Error parsing Input - Invalid Syntax.

CAUSE

This problem occurs because the Dsdbutil.exe utility and the Ntdsutil.exe utility can recognize only the following relative distinguished names:
  • "DC" or "DomainComponent"
  • "CN" or "CommonName"
  • "OU" or "OrganizationalUnitName"
  • "O" or "Organization"
  • "STREET" or "StreetAddress"
  • "L" or "LocalityName"
  • "ST" or "StateOrProvinceName"
  • "C" or "CountryName"

RESOLUTION

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 on the computer.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntdsutil.exe5.2.3790.3265312,83218-Dec-200811:25x86SP1
W03a2409.dll5.2.3790.326540,96018-Dec-200811:02x86SP1
Dsdbutil.exe1.1.3790.3265231,42418-Dec-200811:26x86SP1
Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsutil.exe5.2.3790.3265503,29618-Dec-200822:18x64SP1Not applicable
W03a2409.dll5.2.3790.326541,47218-Dec-200822:18x64SP1Not applicable
Dsdbutil.exe1.1.3790.3265336,38418-Dec-200822:18x64SP1Not applicable
Wntdsutil.exe5.2.3790.3265312,83218-Dec-200822:18x86SP1WOW
Ww03a2409.dll5.2.3790.326540,96018-Dec-200822:18x86SP1WOW
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntdsutil.exe5.2.3790.4430312,83218-Dec-200817:10x86SP2
Dsdbutil.exe1.1.3790.4430231,42418-Dec-200817:11x86SP2
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsutil.exe5.2.3790.4430503,29618-Dec-200822:24x64SP2Not applicable
Dsdbutil.exe1.1.3790.4430336,38418-Dec-200822:24x64SP2Not applicable
Wntdsutil.exe5.2.3790.4430312,83218-Dec-200822:24x86SP2WOW

More information about this hotfix

This hotfix introduces additional functionality by enabling you to use the objectGUID attribute to restore objects. If you want to successfully restore objects that contain non-standard DNs, you must use the objectGUID attribute to restore these objects.

To use the objectGUID attribute to restore an object, follow these steps:
  1. At a command prompt, type the following command, and then press ENTER:
    Repadmin /options serverName:port+DISABLE_INBOUND_REPLICATION
  2. In the Services snap-in, stop the service for the ADAM instance that contains the object.
  3. Restore the database of the ADAM instance.

    For example, you can use the NTBackup.exe utility to perform the backup operation.
  4. Start the service for the ADAM instance.
  5. Use the Ldp.exe utility to bind to the ADAM instance.

    For more information about how to use the Ldp.exe utility, visit the following Microsoft TechNet Web site:
    http://technet.microsoft.com/en-us/library/cc739033.aspx
  6. Locate the object that you want to restore and copy the objectGUID attribute of the object.
  7. Stop the service for the ADAM instance again.
  8. Use the Dsdbutil.exe utility to restore the object. To do this, follow these steps:
    1. Click Start, click Run, type %Windir%\ADAM\Dsdbutil, and then click OK.
    2. At the Dsdbutil.exe: prompt, type activate instance ADAMinstanceName, and then press ENTER.
    3. Type authoritative restore, and then press ENTER.
    4. Type restore object <GUID=objectGUID>, and then press ENTER.

      Note In this step, objectGUID represents the objectGUID attribute of the object that you copied in step 6. For example, <GUID=1212-1211-1212121-121212> indicates that 1212-1211-1212121-121212 is the objectGUID.
  9. Start the service for the ADAM instance.
  10. At a command prompt, run the following command, and then press ENTER:
    Repadmin /options serverName:port -DISABLE_INBOUND_REPLICATION

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684 Description of the standard terminology that is used to describe Microsoft software updates

REFERENCES

For more information about the Dsdbutil.exe utility, visit the following Microsoft TechNet Web site:
http://technet.microsoft.com/en-us/library/cc780814.aspx
For more information about the Ntdsutil.exe utility, visit the following Microsoft TechNet Web site:
http://technet.microsoft.com/en-us/library/cc753343.aspx

Properties

Article ID: 961071 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbexpertiseadvanced kbfix kbautohotfix kbsurveynew kbqfe kbHotfixServer KB961071

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