A .p7b certificate does not import correctly when you try to import it by using the Certificate Import Wizard in MMC on a computer that is running Windows Server 2008 or Windows Vista

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Article ID: 971510 - View products that this article applies to.
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SYMPTOMS

On a computer that is running Windows Server 2008 or Windows Vista, you try to import the .p7b format certificate by using the Certificate Import Wizard in Microsoft Management Console (MMC). However, the certificate does not import correctly. When this issue occurs, you can experience the following symptoms:
  • The imported certificate does not have a private key associated with it.
  • The certificate request object in the Certificate Request store remains.
  • The Certificate Import Wizard completes without displaying any errors.

CAUSE

This problem occurs because .p7b format certificates are not decoded correctly when you import .p7b format certificates from the Certificate Import Wizard in MMC.

RESOLUTION

To resolve this problem, import the certificate by using the certreq -accept command instead of using the Certificate Import Wizard in MMC.

Example:
certreq -accept Certificate.p7b

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 971510 - Last Review: July 21, 2009 - Revision: 2.1
APPLIES TO
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008 R2
  • Windows Web Server 2008
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Keywords: 
kbtshoot kbexpertiseinter KB971510

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