You cannot install a Windows Installer package under the Local System context on a Windows XP-based computer that has update KB956572 installed

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Article ID: 971913 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • On a computer that is running Windows XP Service Pack 3 (SP3), you have the MS09-012 update that is described in Microsoft Knowledge Base (KB) article 956572 installed.
  • You create a software restriction policy that disallows the installation of a certain Windows Installer (MSI) package.
  • You try to install this MSI package under the Local System context.
Note You can schedule the installation of an MSI package under the Local System context by using the at command.

In this scenario, the MSI package does not install and you receive an error message that resembles the following:

The system administrator has set policies to prevent this installation.
Additionally, if you have enabled MSI logging, you can find a record that resembles the following in the MSI installation log:

MainEngineThread is returning 1625

CAUSE

This problem is caused by an error in the update that is described in KB article 956572. This error subjects the Local System account to software restriction policy rules that should not affect the Local System account.

RESOLUTION

Hotfix information

Note The following hotfix applies to the Windows Installer 3.1 package that is included in Windows XP SP3. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP SP3 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msi.dll3.1.4001.58412,843,13607-Jul-200914:05x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

You can enable MSI logging for installation by running the following command when you install an MSI package:

msiexec /i PackageName.msi /l*v c:\PackageName_logging.log

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
956572 MS09-012: Description of the security update for Windows Service Isolation: April 2009

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
310791 Description of the Software Restriction Policies in Windows XP


For more information about normal logging, visit the following Microsoft Web site:
http://msdn.microsoft.com/en-us/library/aa370536(VS.85).aspx
For more information about software restriction policies, visit the following Microsoft Web sites:
http://technet.microsoft.com/en-us/library/cc782792(WS.10).aspx
http://technet.microsoft.com/en-us/library/cc782430(WS.10).aspx

Properties

Article ID: 971913 - Last Review: October 7, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe KB971913

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