The Application Virtualization client service may hang in the "Starting" state

Article translations Article translations
Close Close
Article ID: 973756 - View products that this article applies to.
Expand all | Collapse all
Source: Microsoft Support

RAPID PUBLISHING

RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Symptom

The Application Virtualization Client Service may not complete its startup as indicated by the service remaining in the "Starting" state indefinitely. If this occurs then attempts to launch any virtualized applications may fail.

Cause

This can occur if there is a conflict between the App-V client service and another process that initializes as part of system startup.

Resolution



Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

It may be possible to work around the issue by delaying the start time of the App-V client service until the first user successfully logs in. Follow these steps in order to delay the start of the Application Virtualization Client Service:

Step 1:

  1. Using regedit, navigate to the key named "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run".
  2. Remove the SoftGridTray value from this key. The SoftGridTray value will contain a path. For example:

    SoftGridTray="C:\Program Files\Microsoft Application Virtualization Client\SFTTray.exe" /autostart

Step 2:

  1. Open the "Services" control panel applet.
  2. Display properties for the service called "Application Virtualization Client".
  3. Change the "Startup type" field from "Automatic" to "Manual".

DISCLAIMER

MICROSOFT AND/OR ITS SUPPLIERS MAKE NO REPRESENTATIONS OR WARRANTIES ABOUT THE SUITABILITY, RELIABILITY OR ACCURACY OF THE INFORMATION CONTAINED IN THE DOCUMENTS AND RELATED GRAPHICS PUBLISHED ON THIS WEBSITE (THE “MATERIALS”) FOR ANY PURPOSE. THE MATERIALS MAY INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS AND MAY BE REVISED AT ANY TIME WITHOUT NOTICE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, MICROSOFT AND/OR ITS SUPPLIERS DISCLAIM AND EXCLUDE ALL REPRESENTATIONS, WARRANTIES, AND CONDITIONS WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING BUT NOT LIMITED TO REPRESENTATIONS, WARRANTIES, OR CONDITIONS OF TITLE, NON INFRINGEMENT, SATISFACTORY CONDITION OR QUALITY, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE MATERIALS.

Properties

Article ID: 973756 - Last Review: July 16, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Application Virtualization 4.5 for Windows Desktops
  • Microsoft Application Virtualization 4.5 for Terminal Services
Keywords: 
kbrapidpub kbnomt KB973756

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com