A BizTalk host instance does not start, and event IDs 10514 and 10536 are logged in the Application log

Article translations Article translations
Article ID: 980960 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

In a Microsoft BizTalk Server environment, a BizTalk host instance does not start. Additionally, events that resemble the following are logged in the Application log when this problem occurs:

Event ID: 10514
Source: ENTSSO
Description: An error occurred when trying to access the SSO database.
Function: LookupXp File: lookupserver.cpp:328
Arithmetic overflow error converting IDENTITY to data type int.
Arithmetic overflow occurred.
SQL Error code: 0x00001FB3
Error code: 0xC0002A21, An error occurred while attempting to access the SSO database.

Event ID: 10536
Source: ENTSSO
Description: SSO AUDIT
Function: GetConfigInfo
Tracking ID: GUID
Client Computer: computer_name
Client User: user_name
Application Name: application_name or GUID
Error Code: 0xC0002A21, An error occurred while attempting to access the SSO database.

Note This problem might also occur when you use Enterprise Single Sign-On (ENTSSO) with Host Integration Server.

CAUSE

This problem occurs when the xl_identity column in the dbo.SSOX_AuditXpLookup table in the ENTSSO database reaches its maximum value. The xl_identity column is defined to use an INT data type that has a maximum value of 2,147,483,647. Therefore, when the number in this column exceeds the limit of the INT data type, an arithmetic overflow error occurs.

RESOLUTION

We recommend and support the following solution for this problem. This solution changes the xl_identity column to use a BIGINT data type instead of an INT data type.

To change the column's data type by using Microsoft SQL Server Management Studio (SSMS), follow these steps:
  1. Open SQL Server Management Studio.
  2. Connect to the SQL Server where the ENTSSO database is located.

    Notes
    • You can confirm the name (SSODB is the default database name) and location of the ENTSSO database by using the BizTalk Server or Host Integration Server configuration tool.
    • If the ENTSSO database exists on SQL Server 2008, you must disable the option that prevents saving changes that require table re-creation. To do this, follow these steps:
      1. Open SQL Server Management Studio.
      2. On the Tools menu, click Options.
      3. In the navigation pane of the Options window, click Designers.
      4. Click to clear the Prevent saving changes that require the table re-creation check box, and then click OK.

        Note The Prevent saving changes that require the table re-creation option can be re-enabled after the following changes are made.
  3. Expand the Databases folder.
  4. Locate the Tables folder under the ENTSSO database.
  5. Expand the dbo.SSOX_AuditXpLookup table.
  6. Under the Columns folder, right-click xl_identity and then click Modify.
  7. In the middle pane, select the drop-down in the Data Type column for xl_identity.
  8. Select bigint as the new data type.
  9. On the File menu, click Save SSOX_AuditXpLookup to save the changes.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 980960 - Last Review: March 29, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Standard Edition
  • Microsoft BizTalk Server 2006 R2 Branch Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft Host Integration Server 2006 Enterprise Edition
  • Microsoft Host Integration Server 2006
  • Microsoft Host Integration Server 2009
  • Microsoft BizTalk Adapters for Host Systems
  • Microsoft BizTalk Adapters for Host Systems 2.0
Keywords: 
kbtshoot kbbug kbexpertiseinter kbsurveynew kbprb KB980960

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com