文書番号: 888372 - 最終更新日: 2008年5月16日 - リビジョン: 4.1

Intel 以外のプロセッサを搭載したコンピュータで Windows XP Service Pack 2 または Service Pack 3 にアップグレードすると、エラー メッセージ "Stop 0x0000007E" が表示される

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現象

Intel プロセッサ以外のプロセッサが搭載されているコンピュータを Microsoft Windows XP Service Pack 2 (SP2) または Windows XP Service Pack 3 (SP3) にアップグレードし、コンピュータを再起動すると、以下のエラー メッセージが表示されることがあります。
A problem has been detected and Windows has been shut down to prevent damage to your computer...

Technical information:

*** STOP: 0x0000007E (0xC0000005, 0xFC5CCAF3, 0xFC90F8C0, 0xFC90F5C0) SYSTEM_THREAD_EXCEPTION_NOT_HANDLED
  • Stop エラー メッセージの結果は、コンピュータのシステム障害の設定によって異なる場合があります。
  • Stop エラー メッセージの "Technical information" で、かっこ内に表示される 4 つのパラメータは、コンピュータの構成によって異なる場合があります。ただし、この例の場合、最初のパラメータは必ず "C0000005" と表示されます。
  • "Stop 0x0000007E" エラー メッセージの原因が、必ずしもこの資料に記載されている問題であるとは限りません。

    "Stop 0x0000007E" エラーのトラブルシューティング方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    330182? (http://support.microsoft.com/kb/330182/ ) Windows XP へアップグレード後の "STOP 0x0000007E" エラー メッセージ

原因

ほとんどのコンピュータには、製造元で、システム準備 (Sysprep) ツールを使用して作成されたイメージが含まれています。Sysprep ツールを使用すると、コンピュータの製造元では他のコンピュータで使用できるイメージを生成することができます。「現象」に記載されている問題は、Windows XP Service Pack 1 (SP1) の Sysprep イメージが Intel プロセッサを搭載したコンピュータで作成され、そのイメージを Intel 以外のプロセッサを搭載したコンピュータに展開した場合に発生することがあります。このような構成の場合に、コンピュータを Windows XP SP2 または SP3 にアップグレードすると、元の Sysprep イメージのレジストリ キーが残っているために、Intel プロセッサ ドライバ (Intelppm.sys) によって読み込みが行われることがあります。

この問題は、Windows XP SP2 または Windows XP SP3 の Sysprep イメージが、Intel プロセッサを搭載したコンピュータで作成され、そのイメージを Intel 以外のプロセッサを搭載したコンピュータに展開した場合にも発生します。この場合にも、元の Sysprep イメージのレジストリ キーが残っているために、Intel プロセッサ ドライバ (Intelppm.sys) によって読み込みが行われることがあります。

元のイメージが作成されたプロセッサとは製造元が異なるプロセッサを搭載しているコンピュータに、Sysprep イメージを展開するときのサポートされていない事例についての詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
828287? (http://support.microsoft.com/kb/828287/ ) Sysprep でサポートされていない使用方法

: 異なるプロセッサを搭載しているコンピュータを使用してイメージが作成された場合、Sysprep を使用してそのイメージからオペレーティング システムをインストールすることはサポートされていません。たとえば、Intel プロセッサを搭載したコンピュータで Sysprep イメージを作成し、そのイメージを AMD プロセッサを搭載したコンピュータに展開することはできません。

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

解決方法

重要 : このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを編集する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしておくと、問題が発生した場合にレジストリを復元することができます。バックアップおよび復元方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322756? (http://support.microsoft.com/kb/322756/ ) Windows でレジストリをバックアップおよび復元する方法


この問題を解決するには、以下の手順を実行します。
  1. コンピュータをセーフ モードで起動します。

    Windows XP のセーフ モードの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    315222? (http://support.microsoft.com/kb/315222/ ) Windows XP のセーフ モード ブート オプションについて
  2. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。regedit と入力し [OK] をクリックします。
  3. 次のレジストリ キーを見つけてクリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Intelppm
  4. 右側のウィンドウで [Start] を右クリックし、[修正] をクリックします。
  5. [値のデータ] ボックスに 4 と入力し、[OK] をクリックします。
  6. レジストリ エディタを終了します。
  7. コンピュータを再起動します。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Service Pack 3?を以下の環境でお使いの場合
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
キーワード:?
kbsetup kberrmsg kbtshoot KB888372
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